summaryrefslogtreecommitdiff
path: root/x11-misc/rodent/rodent-5.3.16.3-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-12-01 03:04:39 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-12-01 03:04:39 +0000
commit407525b571b48cfd65e1ad7a02d250a927c967c9 (patch)
tree844bea44d85dc7218f54970af1c42cc9d55c3f1a /x11-misc/rodent/rodent-5.3.16.3-r1.ebuild
parent89c6c06b8c42107dd231687a1012354e7d3039fc (diff)
gentoo resync : 01.12.2017
Diffstat (limited to 'x11-misc/rodent/rodent-5.3.16.3-r1.ebuild')
-rw-r--r--x11-misc/rodent/rodent-5.3.16.3-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/x11-misc/rodent/rodent-5.3.16.3-r1.ebuild b/x11-misc/rodent/rodent-5.3.16.3-r1.ebuild
new file mode 100644
index 000000000000..ad96bd85d815
--- /dev/null
+++ b/x11-misc/rodent/rodent-5.3.16.3-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools gnome2-utils xdg-utils
+
+DESCRIPTION="A fast, small and powerful file manager and graphical shell"
+HOMEPAGE="http://xffm.org/"
+SRC_URI="mirror://sourceforge/xffm/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=x11-libs/librfm-5.3.16.3"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS ChangeLog TODO )
+
+src_prepare() {
+ pushd apps/rodent-pkg >/dev/null || die
+ sed -i -e "/^install-data-hook/d" \
+ -e "/rm -f/d" Build/Makefile.am || die
+ eautoreconf
+ popd >/dev/null || die
+ default
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}