summaryrefslogtreecommitdiff
path: root/x11-misc/qxkb/qxkb-0.5.1_pre20190821.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-25 11:37:10 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-25 11:37:10 +0100
commit38423c67c8a23f6a1bc42038193182e2da3116eb (patch)
tree04e2cf4bd43601b77daa79fe654e409187093c5e /x11-misc/qxkb/qxkb-0.5.1_pre20190821.ebuild
parent623ee73d661e5ed8475cb264511f683407d87365 (diff)
gentoo resync : 25.04.2020
Diffstat (limited to 'x11-misc/qxkb/qxkb-0.5.1_pre20190821.ebuild')
-rw-r--r--x11-misc/qxkb/qxkb-0.5.1_pre20190821.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/x11-misc/qxkb/qxkb-0.5.1_pre20190821.ebuild b/x11-misc/qxkb/qxkb-0.5.1_pre20190821.ebuild
new file mode 100644
index 000000000000..740ed9271fbc
--- /dev/null
+++ b/x11-misc/qxkb/qxkb-0.5.1_pre20190821.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+COMMIT=ee9a1eee9dc810b33b931601203051d841bc3e7a
+inherit cmake
+
+DESCRIPTION="Qt-based keyboard layout switcher"
+HOMEPAGE="https://github.com/disels/qxkb"
+SRC_URI="https://github.com/disels/qxkb/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+PATCHES=( "${FILESDIR}/${P}-desktop.patch" )
+
+BDEPEND="
+ dev-qt/linguist-tools:5
+"
+DEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ x11-libs/libX11
+ x11-libs/libxkbfile
+"
+RDEPEND="${DEPEND}
+ x11-apps/setxkbmap
+"