summaryrefslogtreecommitdiff
path: root/x11-misc/qcomicbook
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-02-17 10:35:54 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-02-17 10:35:54 +0000
commit463397cf1e064185110fe57c568d73f99a06f5d1 (patch)
tree9aa75eefc5154eaf0e3c33658b830fc54dc68052 /x11-misc/qcomicbook
parentc8d60dada2ec8eb48b2d2b290cd6683ccec40e39 (diff)
gentoo resync : 17.02.2021
Diffstat (limited to 'x11-misc/qcomicbook')
-rw-r--r--x11-misc/qcomicbook/Manifest2
-rw-r--r--x11-misc/qcomicbook/qcomicbook-0.9.1.ebuild27
2 files changed, 14 insertions, 15 deletions
diff --git a/x11-misc/qcomicbook/Manifest b/x11-misc/qcomicbook/Manifest
index d1fe86a715c5..5d283c86d2a0 100644
--- a/x11-misc/qcomicbook/Manifest
+++ b/x11-misc/qcomicbook/Manifest
@@ -1,3 +1,3 @@
DIST qcomicbook-0.9.1.tar.gz 739887 BLAKE2B c4072e849f173bc6014e1765adc18ac359e5508b5c6bb110782bb92c81fe7683911a68910976cba16263950d9ac9b9ad53de44c4cd692d0bd24374c38012ebbe SHA512 87bd983c4442e220f1bc463e54e0ea583cddbc6becd9eec64801dc5e7e061cdac5805cba83167685ab454e41fcce329fa399d622d7f588940bf057ce4b1f423d
-EBUILD qcomicbook-0.9.1.ebuild 1644 BLAKE2B a1bae2b0284d9268c625c1911d7cd3dc57a27af8b1cf0829591d5a8979fd5d986e649649ac846237bcbb177a9d0ffbe5b38c14c3086ef4958699d2f9292f3e5e SHA512 2681ca210738433495d5d0934aaa7b80d532e5e5093b66ec8a7ddc092fc794b94164948cbe66f5bd912ccf355d2e9c5f8808faaaa1d2a24373bb70a22d8134be
+EBUILD qcomicbook-0.9.1.ebuild 1621 BLAKE2B b42a54d50841d54c6bc88a4ceddce1727ba5b8f3553dda6d8ee76a089452a7a2aa8428f1bdbdb3fea7c53d6a0a93de1387b4ccf53d2afc9d4fd35104b36aa20c SHA512 0851e70d9161b6c323e41d7a0909ebe1b1fbf1f60b41ae3db54541ee7a0775b8f3577577abe5d146a01662683c8e198ad68eaea2d8000f0e6182a1bf97e2a1f8
MISC metadata.xml 469 BLAKE2B 09213bed780c0d2f966fb7ba16c052ad397999be2e6e238c8e915ebbbb938f3210409e2d7961c629ae0d8abb20efa99b2b833d2cd268e7239ead845294b8fc68 SHA512 4c8f85cb1afed375e4b2c19e873c2c70ca7c11f139305af70a2b8556230ddd17f52753b1302c8d5547b4922e35c1922fdc001e62b420645f1c36097ebf5e855b
diff --git a/x11-misc/qcomicbook/qcomicbook-0.9.1.ebuild b/x11-misc/qcomicbook/qcomicbook-0.9.1.ebuild
index ec3dbfe2f756..e17000ce7a5a 100644
--- a/x11-misc/qcomicbook/qcomicbook-0.9.1.ebuild
+++ b/x11-misc/qcomicbook/qcomicbook-0.9.1.ebuild
@@ -1,14 +1,14 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
MY_PN="QComicBook"
CMAKE_IN_SOURCE_BUILD=1
PLOCALES="cs_CZ de_DE es_ES fi_FI fr_CA fr_FR it_IT ko_KR nl_NL pl_PL pt_BR ru_RU uk_UA zh_CN"
-inherit cmake-utils flag-o-matic l10n xdg
+inherit cmake flag-o-matic l10n xdg
-DESCRIPTION="A viewer for comic book archives containing jpeg/png images"
+DESCRIPTION="Viewer for comic book archives containing jpeg/png images"
HOMEPAGE="https://github.com/stolowski/QComicBook"
SRC_URI="https://github.com/stolowski/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
@@ -17,15 +17,15 @@ SLOT="0"
KEYWORDS="amd64 ~ppc x86"
IUSE="debug"
-RDEPEND="app-text/poppler[qt5]
+RDEPEND="
+ app-text/poppler[qt5]
dev-qt/qtcore:5
dev-qt/qtgui:5
dev-qt/qtprintsupport:5
dev-qt/qtwidgets:5
dev-qt/qtx11extras:5"
-DEPEND="${RDEPEND}
- dev-qt/linguist-tools:5
-"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-qt/linguist-tools:5"
DOCS=( AUTHORS ChangeLog NEWS README THANKS TODO )
@@ -33,25 +33,24 @@ S="${WORKDIR}/${MY_PN}-${PV}"
src_prepare() {
rm_loc() {
- rm "i18n/${PN}_${1}.ts" || die "removing ${1} locale failed"
+ rm "i18n/${PN}_${1}.ts" || die "removing ${1} locale failed"
}
rm "i18n/${PN}_en_EN.ts" || die 'removing redundant english locale failed'
l10n_find_plocales_changes "i18n" "${PN}_" ".ts"
l10n_for_each_disabled_locale_do rm_loc
# fix desktop file
- sed -i \
- -e '/^Encoding/d' \
+ sed -e '/^Encoding/d' \
-e '/^Icon/s/.png//' \
-e '/^Categories/s/Application;//' \
- "data/${PN}.desktop" || die 'sed on desktop file failed'
+ -i data/${PN}.desktop || die 'sed on desktop file failed'
- cmake-utils_src_prepare
+ cmake_src_prepare
}
src_configure() {
use !debug && append-cppflags -DQT_NO_DEBUG_OUTPUT
- cmake-utils_src_configure
+ cmake_src_configure
}
pkg_postinst() {