summaryrefslogtreecommitdiff
path: root/x11-misc/qarma/qarma-1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /x11-misc/qarma/qarma-1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'x11-misc/qarma/qarma-1.ebuild')
-rw-r--r--x11-misc/qarma/qarma-1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/x11-misc/qarma/qarma-1.ebuild b/x11-misc/qarma/qarma-1.ebuild
new file mode 100644
index 000000000000..e1c4f05d258e
--- /dev/null
+++ b/x11-misc/qarma/qarma-1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit qmake-utils
+
+DESCRIPTION="Zenity Clone for Qt5"
+HOMEPAGE="https://github.com/luebking/qarma"
+SRC_URI="https://github.com/luebking/qarma/archive/t${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-qt/qtcore:5 dev-qt/qtgui:5 dev-qt/qtwidgets:5 dev-qt/qtx11extras:5"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}-t${PV}"
+
+src_configure() {
+ eqmake5
+}
+
+src_install() {
+ dobin qarma
+}