summaryrefslogtreecommitdiff
path: root/x11-misc/pypanel/pypanel-2.4-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /x11-misc/pypanel/pypanel-2.4-r2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'x11-misc/pypanel/pypanel-2.4-r2.ebuild')
-rw-r--r--x11-misc/pypanel/pypanel-2.4-r2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/x11-misc/pypanel/pypanel-2.4-r2.ebuild b/x11-misc/pypanel/pypanel-2.4-r2.ebuild
new file mode 100644
index 000000000000..c1c3381177d7
--- /dev/null
+++ b/x11-misc/pypanel/pypanel-2.4-r2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+MY_PN=${PN/pyp/PyP}
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="A lightweight panel/taskbar for X11 window managers"
+HOMEPAGE="http://pypanel.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc ~ppc64 x86"
+IUSE=""
+
+RDEPEND="x11-libs/libXft
+ dev-python/python-xlib[${PYTHON_USEDEP}]
+ media-libs/imlib2[X]"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${MY_P}