summaryrefslogtreecommitdiff
path: root/x11-misc/polybar/polybar-3.6.3-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-11 14:17:10 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-11 14:17:10 +0100
commit5adfd733728a4f14df5665f4c2a604a7356e5f19 (patch)
treef2938c4a08576b45508b02481edfec55eac3ac8b /x11-misc/polybar/polybar-3.6.3-r3.ebuild
parentfbba40085f5d1591a67b49f5aa48b4071b7560f1 (diff)
gentoo auto-resync : 11:06:2023 - 14:17:09
Diffstat (limited to 'x11-misc/polybar/polybar-3.6.3-r3.ebuild')
-rw-r--r--x11-misc/polybar/polybar-3.6.3-r3.ebuild64
1 files changed, 64 insertions, 0 deletions
diff --git a/x11-misc/polybar/polybar-3.6.3-r3.ebuild b/x11-misc/polybar/polybar-3.6.3-r3.ebuild
new file mode 100644
index 000000000000..00bf5147d168
--- /dev/null
+++ b/x11-misc/polybar/polybar-3.6.3-r3.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit cmake python-single-r1
+
+DESCRIPTION="A fast and easy-to-use tool for creating status bars"
+HOMEPAGE="https://github.com/polybar/polybar"
+SRC_URI="https://github.com/polybar/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+KEYWORDS="amd64 ~riscv x86"
+LICENSE="MIT"
+SLOT="0"
+IUSE="alsa curl doc i3wm ipc mpd network pulseaudio"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep 'x11-base/xcb-proto[${PYTHON_USEDEP}]')
+ dev-libs/libuv:=
+ media-libs/fontconfig
+ media-libs/freetype
+ x11-libs/cairo[X,xcb(+)]
+ x11-libs/libxcb:=
+ x11-libs/xcb-util
+ x11-libs/xcb-util-cursor
+ x11-libs/xcb-util-image
+ x11-libs/xcb-util-wm
+ x11-libs/xcb-util-xrm
+ alsa? ( media-libs/alsa-lib )
+ curl? ( net-misc/curl )
+ doc? ( dev-python/sphinx )
+ i3wm? (
+ dev-libs/jsoncpp:=
+ x11-wm/i3
+ )
+ mpd? ( media-libs/libmpdclient )
+ network? ( dev-libs/libnl:3 )
+ pulseaudio? ( media-libs/libpulse )
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${P}-fix-prefix.patch" )
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_ALSA="$(usex alsa)"
+ -DENABLE_CURL="$(usex curl)"
+ -DBUILD_DOC="$(usex doc)"
+ -DENABLE_I3="$(usex i3wm)"
+ -DBUILD_POLYBAR_MSG="$(usex ipc)"
+ -DENABLE_MPD="$(usex mpd)"
+ -DENABLE_NETWORK="$(usex network)"
+ -DENABLE_PULSEAUDIO="$(usex pulseaudio)"
+ # Bug 767949
+ -DENABLE_CCACHE="OFF"
+ -DCMAKE_INSTALL_SYSCONFDIR="${EPREFIX}/etc/"
+ )
+
+ cmake_src_configure
+}