summaryrefslogtreecommitdiff
path: root/x11-misc/picom/picom-8.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-08 11:28:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-08 11:28:34 +0000
commit24fd814c326e282c4321965c31f341dad77e270d (patch)
tree033d63b33c21a3209964ab56005bb9bdd523630d /x11-misc/picom/picom-8.ebuild
parent129160ec854dca4c3fedb5bcfbcb56930371da0f (diff)
gentoo resync : 08.01.2021
Diffstat (limited to 'x11-misc/picom/picom-8.ebuild')
-rw-r--r--x11-misc/picom/picom-8.ebuild60
1 files changed, 0 insertions, 60 deletions
diff --git a/x11-misc/picom/picom-8.ebuild b/x11-misc/picom/picom-8.ebuild
deleted file mode 100644
index 2530591a444a..000000000000
--- a/x11-misc/picom/picom-8.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7,8} )
-inherit meson python-any-r1 virtualx xdg
-
-DESCRIPTION="A lightweight compositor for X11 (previously a compton fork)"
-HOMEPAGE="https://github.com/yshui/picom"
-SRC_URI="https://github.com/yshui/picom/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MPL-2.0 MIT"
-SLOT="0"
-KEYWORDS="amd64 ~ppc64 x86"
-IUSE="+config-file dbus +doc +drm opengl pcre test"
-
-REQUIRED_USE="test? ( dbus )" # avoid "DBus support not compiled in!"
-RESTRICT="test" # but tests require dbus_next
-
-RDEPEND="
- dev-libs/libev
- dev-libs/uthash
- x11-libs/libX11
- x11-libs/libxcb
- x11-libs/libXext
- x11-libs/pixman
- x11-libs/xcb-util-image
- x11-libs/xcb-util-renderutil
- config-file? (
- dev-libs/libconfig
- dev-libs/libxdg-basedir
- )
- dbus? ( sys-apps/dbus )
- drm? ( x11-libs/libdrm )
- opengl? ( virtual/opengl )
- pcre? ( dev-libs/libpcre )
- !x11-misc/compton"
-DEPEND="${RDEPEND}
- x11-base/xorg-proto"
-BDEPEND="virtual/pkgconfig
- doc? ( app-text/asciidoc )
- test? ( $(python_gen_any_dep 'dev-python/xcffib[${PYTHON_USEDEP}]') )
-"
-
-src_configure() {
- local emesonargs=(
- $(meson_use config-file config_file)
- $(meson_use dbus)
- $(meson_use doc with_docs)
- $(meson_use opengl)
- $(meson_use pcre regex)
- )
-
- meson_src_configure
-}
-
-src_test() {
- virtx "${S}/tests/run_tests.sh" "${BUILD_DIR}/src/${PN}"
-}