summaryrefslogtreecommitdiff
path: root/x11-misc/parcellite/parcellite-1.2.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-10-20 10:22:14 +0100
committerV3n3RiX <venerix@koprulu.sector>2021-10-20 10:22:14 +0100
commit46eedbedafdb0040c37884982d4c775ce277fb7b (patch)
treedb33a91259730be84999e13a8d8168c799f50ac0 /x11-misc/parcellite/parcellite-1.2.1.ebuild
parente23a08d0c97a0cc415aaa165da840b056f93c997 (diff)
gentoo resync : 20.10.2021
Diffstat (limited to 'x11-misc/parcellite/parcellite-1.2.1.ebuild')
-rw-r--r--x11-misc/parcellite/parcellite-1.2.1.ebuild32
1 files changed, 11 insertions, 21 deletions
diff --git a/x11-misc/parcellite/parcellite-1.2.1.ebuild b/x11-misc/parcellite/parcellite-1.2.1.ebuild
index b89ab441c540..d9bab58ad41d 100644
--- a/x11-misc/parcellite/parcellite-1.2.1.ebuild
+++ b/x11-misc/parcellite/parcellite-1.2.1.ebuild
@@ -1,51 +1,41 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=8
-inherit autotools eutils xdg-utils
+inherit autotools xdg
MY_P=${PN}-${PV/_}
DESCRIPTION="A lightweight GTK+ based clipboard manager"
HOMEPAGE="http://parcellite.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="amd64 ~ppc x86"
IUSE="nls"
-RDEPEND=">=dev-libs/glib-2.14
- >=x11-libs/gtk+-2.10:2
+RDEPEND="
+ dev-libs/glib:2
+ x11-libs/gtk+:2
x11-misc/xdotool"
-DEPEND="${RDEPEND}
+DEPEND="${RDEPEND}"
+BDEPEND="
virtual/pkgconfig
nls? (
dev-util/intltool
sys-devel/gettext
)"
-S=${WORKDIR}/${MY_P}
+PATCHES=( "${FILESDIR}"/${P}-desktop-QA.patch )
src_prepare() {
- sed -i data/${PN}.desktop.in -e 's:Application;::g' || die
-
- sed -i -e '/^ALL_LINGUAS=/d' configure.ac || die
- strip-linguas -i po/
- export ALL_LINGUAS="${LINGUAS}"
-
+ default
eautoreconf
}
src_configure() {
econf $(use_enable nls)
}
-
-pkg_postinst() {
- xdg_desktop_database_update
-}
-
-pkg_postrm() {
- xdg_desktop_database_update
-}