summaryrefslogtreecommitdiff
path: root/x11-misc/notification-daemon/notification-daemon-0.5.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /x11-misc/notification-daemon/notification-daemon-0.5.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'x11-misc/notification-daemon/notification-daemon-0.5.0.ebuild')
-rw-r--r--x11-misc/notification-daemon/notification-daemon-0.5.0.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/x11-misc/notification-daemon/notification-daemon-0.5.0.ebuild b/x11-misc/notification-daemon/notification-daemon-0.5.0.ebuild
new file mode 100644
index 000000000000..c07fd3c8dd70
--- /dev/null
+++ b/x11-misc/notification-daemon/notification-daemon-0.5.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+GCONF_DEBUG=no
+GNOME2_LA_PUNT=yes
+GNOME_TARBALL_SUFFIX=bz2
+
+inherit autotools eutils gnome2
+
+DESCRIPTION="Notification daemon"
+HOMEPAGE="https://git.gnome.org/browse/notification-daemon/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="sh"
+IUSE=""
+
+RDEPEND=">=dev-libs/glib-2
+ >=x11-libs/gtk+-2.18:2
+ >=gnome-base/gconf-2
+ >=dev-libs/dbus-glib-0.100
+ >=sys-apps/dbus-1
+ >=media-libs/libcanberra-0.4[gtk]
+ x11-libs/libnotify
+ x11-libs/libwnck:1
+ x11-libs/libX11
+ !x11-misc/notify-osd
+ !x11-misc/qtnotifydaemon"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.50
+ gnome-base/gnome-common
+ >=sys-devel/gettext-0.18
+ virtual/pkgconfig"
+
+DOCS="AUTHORS ChangeLog NEWS"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-libnotify-0.7.patch \
+ "${FILESDIR}"/${P}-underlinking.patch
+
+ eautoreconf
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure --disable-static
+}