summaryrefslogtreecommitdiff
path: root/x11-misc/mixer_app/mixer_app-1.8.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-06-30 08:49:38 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-06-30 08:49:38 +0100
commitb2be182d49eea46686b5cf2680d457df61e89dc4 (patch)
treec66442ced2011c5ca81c3114cc51041e314c6d33 /x11-misc/mixer_app/mixer_app-1.8.0-r1.ebuild
parente23cdda4dbb0c83b9e682ab5e916085a35203da5 (diff)
gentoo resync : 30.06.2018
Diffstat (limited to 'x11-misc/mixer_app/mixer_app-1.8.0-r1.ebuild')
-rw-r--r--x11-misc/mixer_app/mixer_app-1.8.0-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/x11-misc/mixer_app/mixer_app-1.8.0-r1.ebuild b/x11-misc/mixer_app/mixer_app-1.8.0-r1.ebuild
new file mode 100644
index 000000000000..45d98e6279df
--- /dev/null
+++ b/x11-misc/mixer_app/mixer_app-1.8.0-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+MY_P=Mixer.app-${PV}
+
+DESCRIPTION="mixer_app has volume controllers that can be configured to handle sound sources"
+HOMEPAGE="http://www.fukt.bsnet.se/~per/mixer/"
+SRC_URI="http://www.fukt.bsnet.se/~per/mixer/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}
+ virtual/os-headers
+ x11-base/xorg-proto"
+
+S=${WORKDIR}/${MY_P}
+
+DOCS=( ChangeLog README )
+
+PATCHES=( "${FILESDIR}"/${P}-build.patch )
+
+src_compile() {
+ tc-export CXX
+ emake
+}