summaryrefslogtreecommitdiff
path: root/x11-misc/lightdm
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-20 11:40:14 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-20 11:40:14 +0000
commit11d4aa3149c1654953e22c50bf718b340406b158 (patch)
tree00a7d2ae92a6bc09e8668eb94a96384a303f1706 /x11-misc/lightdm
parente660fe12946bfa241d169ebb2467939907de75d8 (diff)
gentoo auto-resync : 20:01:2023 - 11:40:14
Diffstat (limited to 'x11-misc/lightdm')
-rw-r--r--x11-misc/lightdm/Manifest1
-rw-r--r--x11-misc/lightdm/lightdm-1.32.0-r2.ebuild167
2 files changed, 168 insertions, 0 deletions
diff --git a/x11-misc/lightdm/Manifest b/x11-misc/lightdm/Manifest
index 90b0aab7458c..9ebdc0a54bea 100644
--- a/x11-misc/lightdm/Manifest
+++ b/x11-misc/lightdm/Manifest
@@ -11,4 +11,5 @@ DIST lightdm-1.30.0.tar.xz 509220 BLAKE2B 5b6fcc6b955d7a7eb3a810a7e28707a812810d
DIST lightdm-1.32.0.tar.xz 518168 BLAKE2B 90191559895a58e2c5892705ea95766aaaaa87d3470f1372ab90fcf3991d27f9280d5bbabe0cfce70e25f960d63c1e7eab7beeeb501341996afd155788cbe1c7 SHA512 81497fb25904bc2e8687dc99992628eb534f7418f72e1908c4766e917fc1221714210d998739417e1cae2ee15e3197a2eb8d4981cb944cfeb0334dc9e356e716
EBUILD lightdm-1.30.0-r3.ebuild 4139 BLAKE2B bb436a18ccb2e229b57ec10be9524542fc81dae8034b802b00dee64b69f704723a9d79b270c2a46ac056edb837c47827c7fab9fe36efe78ce4015f0cda886d20 SHA512 c004da29823aa0dd3db06c22a0bb36548d6d25a593636cff79511c1972b695f1b7920e17f23f4a7b911b7bfd45e0bc1cfea81986bf7d92c463536ca3549740f7
EBUILD lightdm-1.32.0-r1.ebuild 4143 BLAKE2B ba5dcc3c64e8d49514ac9c863dd8f0f6c16247667e3a83b74fcce5b528061b218e0629421c6b029ce59fc21d66b521a8e8a0f703ac52f5d89e0874c39e82812a SHA512 f8200c98656b35f078a5858193c364b2c33cbe9d5957d3c6e439380eb18b93b9de315d84e2d0aa13e57cc7fca30f165242495ad0ad78a47a516fc94afcf5f8c7
+EBUILD lightdm-1.32.0-r2.ebuild 4546 BLAKE2B fde4292af8e9c3f709c3420669e7c8aa57f8cdfb369d7bef0e44291541cd134fa14834991c4e3f7e83746f5baeb6d50a4c29ef069fa28181d68dd4477e55066c SHA512 282b18efd5debb5edb24fb9d48115ab9817f4a1880c837c34b79d83e17590df8078486a9812030ec5216ae8d9b8f501c7a152d80732bf3cbce8a9c1dea98b9a5
MISC metadata.xml 454 BLAKE2B 66c069f7c5e3b820059e67736ebd898389a8243bce08fd364c8d0a1704f484a13a935bc2a7a31ad975535f8df5a091cbc337c48ea65f45a1cebdcb2c0888b8dc SHA512 f5e5c7467eef552ac808daa8289f803438fc72c81028b48cb20f4f18ff2462216520312294eeff8fffc1357a4330e1e264da70dd35ef3c20baff2c5c26bc654e
diff --git a/x11-misc/lightdm/lightdm-1.32.0-r2.ebuild b/x11-misc/lightdm/lightdm-1.32.0-r2.ebuild
new file mode 100644
index 000000000000..1209f8df2a34
--- /dev/null
+++ b/x11-misc/lightdm/lightdm-1.32.0-r2.ebuild
@@ -0,0 +1,167 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools pam qmake-utils readme.gentoo-r1 systemd vala xdg-utils
+
+DESCRIPTION="A lightweight display manager"
+HOMEPAGE="https://github.com/canonical/lightdm"
+SRC_URI="https://github.com/canonical/lightdm/releases/download/${PV}/${P}.tar.xz
+ mirror://gentoo/introspection-20110205.m4.tar.bz2"
+
+LICENSE="GPL-3 LGPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86"
+IUSE="audit elogind +gnome +gtk +introspection non-root qt5 systemd vala"
+
+REQUIRED_USE="^^ ( elogind systemd )
+ vala? ( introspection )"
+
+RESTRICT="test"
+
+COMMON_DEPEND="
+ >=dev-libs/glib-2.44.0:2
+ dev-libs/libgcrypt:=
+ dev-libs/libxml2
+ sys-libs/pam
+ x11-libs/libX11
+ >=x11-libs/libxklavier-5
+ audit? ( sys-process/audit )
+ gnome? ( sys-apps/accountsservice )
+ introspection? ( >=dev-libs/gobject-introspection-1 )
+ qt5? (
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ )
+"
+RDEPEND="${COMMON_DEPEND}
+ acct-group/lightdm
+ acct-group/video
+ acct-user/lightdm
+ >=sys-auth/pambase-20101024-r2
+ elogind? ( sys-auth/elogind[pam] )
+ systemd? ( sys-apps/systemd[pam] )"
+DEPEND="${COMMON_DEPEND}
+ gnome? ( gnome-base/gnome-common )
+"
+BDEPEND="
+ dev-util/gtk-doc-am
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )
+"
+PDEPEND="gtk? ( x11-misc/lightdm-gtk-greeter )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.30.0-musl-locale.patch
+ "${FILESDIR}"/${PN}-1.30.0-musl-updwtmpx.patch
+)
+
+DOCS=( NEWS )
+
+pkg_setup() {
+ export LIGHTDM_USER=${LIGHTDM_USER:-lightdm}
+ vala_setup
+}
+
+src_prepare() {
+ xdg_environment_reset
+
+ sed -i -e 's:getgroups:lightdm_&:' tests/src/libsystem.c || die #412369
+ sed -i -e '/minimum-uid/s:500:1000:' data/users.conf || die
+
+ einfo "Fixing the session-wrapper variable in lightdm.conf"
+ sed -i -e \
+ "/^#session-wrapper/s@^.*@session-wrapper=/etc/${PN}/Xsession@" \
+ data/lightdm.conf || die "Failed to fix lightdm.conf"
+
+ # use correct version of qmake. bug #566950
+ sed \
+ -e "/AC_CHECK_TOOLS(MOC5/a AC_SUBST(MOC5,$(qt5_get_bindir)/moc)" \
+ -i configure.ac || die
+
+ default
+
+ # Remove bogus Makefile statement. This needs to go upstream
+ sed -i /"@YELP_HELP_RULES@"/d help/Makefile.am || die
+ if has_version dev-libs/gobject-introspection; then
+ eautoreconf
+ else
+ AT_M4DIR=${WORKDIR} eautoreconf
+ fi
+}
+
+src_configure() {
+ # Set default values if global vars unset
+ local _greeter _session _user
+ _greeter=${LIGHTDM_GREETER:=lightdm-gtk-greeter}
+ _session=${LIGHTDM_SESSION:=gnome}
+ _user="$(usex non-root "${LIGHTDM_USER}" root)"
+ # Let user know how lightdm is configured
+ einfo "Gentoo configuration"
+ einfo "Default greeter: ${_greeter}"
+ einfo "Default session: ${_session}"
+ einfo "Greeter user: ${_user}"
+
+ # also disable tests because libsystem.c does not build. Tests are
+ # restricted so it does not matter anyway.
+ local myeconfargs=(
+ --localstatedir=/var
+ --disable-static
+ --disable-tests
+ $(use_enable audit libaudit)
+ $(use_enable introspection)
+ $(use_enable qt5 liblightdm-qt5)
+ $(use_enable vala)
+ --with-user-session=${_session}
+ --with-greeter-session=${_greeter}
+ --with-greeter-user=${_user}
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ # Delete apparmor profiles because they only work with Ubuntu's
+ # apparmor package. Bug #494426
+ if [[ -d ${ED}/etc/apparmor.d ]]; then
+ rm -r "${ED}/etc/apparmor.d" || die \
+ "Failed to remove apparmor profiles"
+ fi
+
+ insinto /etc/${PN}
+ doins data/{${PN},keys}.conf
+ newins "${FILESDIR}"/Xsession-r1 Xsession
+ fperms +x /etc/${PN}/Xsession
+ # /var/lib/lightdm-data could be useful. Bug #522228
+ keepdir /var/lib/${PN}-data
+
+ find "${ED}" -type f \( -name '*.a' -o -name "*.la" \) -delete || die
+ rm -r "${ED}"/etc/init || die
+
+ # Remove existing pam file. We will build a new one. Bug #524792
+ rm -r "${ED}"/etc/pam.d/${PN}{,-greeter} || die
+ pamd_mimic system-local-login ${PN} auth account password session #372229
+ pamd_mimic system-local-login ${PN}-greeter auth account password session #372229
+ dopamd "${FILESDIR}"/${PN}-autologin #390863, #423163
+
+ readme.gentoo_create_doc
+
+ systemd_newunit "${FILESDIR}"/${PN}.service-r1 ${PN}.service
+}
+
+pkg_postinst() {
+ systemd_reenable "${PN}.service"
+
+ # Bug #886607
+ ewarn
+ ewarn "If you have a Nvidia GPU and ${PN} fails to launch X, edit /etc/${PN}/${PN}.conf to include the line"
+ ewarn
+ ewarn "logind-check-graphical=false"
+ ewarn
+ ewarn "in the section [LightDM]. See https://github.com/canonical/lightdm/issues/263 for details."
+}