summaryrefslogtreecommitdiff
path: root/x11-misc/gxmessage/gxmessage-2.20.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-05 18:44:56 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-05 18:44:56 +0000
commit29aabba0ea759c6a2864ff5631735b67ee38e5e0 (patch)
treeab466b4dfa7abecb401b2f8039d08af4689306bb /x11-misc/gxmessage/gxmessage-2.20.4.ebuild
parentd42200bec37eef2a7478d88988ff00addd0a9202 (diff)
gentoo resync : 05.02.2020
Diffstat (limited to 'x11-misc/gxmessage/gxmessage-2.20.4.ebuild')
-rw-r--r--x11-misc/gxmessage/gxmessage-2.20.4.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/x11-misc/gxmessage/gxmessage-2.20.4.ebuild b/x11-misc/gxmessage/gxmessage-2.20.4.ebuild
new file mode 100644
index 000000000000..e02454624a6c
--- /dev/null
+++ b/x11-misc/gxmessage/gxmessage-2.20.4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit xdg-utils
+
+DESCRIPTION="A GTK+ based xmessage clone"
+HOMEPAGE="https://savannah.gnu.org/projects/gxmessage/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3 public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+RDEPEND="
+ >=x11-libs/gtk+-2.20:2
+"
+DEPEND="
+ ${RDEPEND}
+ >=dev-util/intltool-0.40.1
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+DOCS=( AUTHORS ChangeLog HACKING NEWS README TODO )
+
+src_install() {
+ default
+
+ docinto examples
+ dodoc examples/*
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}