summaryrefslogtreecommitdiff
path: root/x11-misc/gtkdialog/gtkdialog-0.8.3-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /x11-misc/gtkdialog/gtkdialog-0.8.3-r2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'x11-misc/gtkdialog/gtkdialog-0.8.3-r2.ebuild')
-rw-r--r--x11-misc/gtkdialog/gtkdialog-0.8.3-r2.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/x11-misc/gtkdialog/gtkdialog-0.8.3-r2.ebuild b/x11-misc/gtkdialog/gtkdialog-0.8.3-r2.ebuild
new file mode 100644
index 000000000000..bf0610c4fd83
--- /dev/null
+++ b/x11-misc/gtkdialog/gtkdialog-0.8.3-r2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools
+
+DESCRIPTION="A small utility for fast and easy GUI building"
+HOMEPAGE="https://code.google.com/p/gtkdialog/"
+SRC_URI="https://${PN}.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="glade vte"
+
+RDEPEND="
+ x11-libs/gtk+:2
+ glade? ( gnome-base/libglade )
+ vte? ( x11-libs/vte:0= )
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+ sys-devel/flex
+ virtual/yacc
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.8.3-optdeps.patch
+)
+
+src_prepare() {
+ mv configure.{in,ac} || die
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_with glade) $(use_with vte)
+}
+
+src_install() {
+ # Stop make install from running gtk-update-icon-cache
+ emake DESTDIR="${D}" UPDATE_ICON_CACHE=true install
+ einstalldocs
+}