summaryrefslogtreecommitdiff
path: root/x11-misc/grun/grun-0.9.3-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /x11-misc/grun/grun-0.9.3-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'x11-misc/grun/grun-0.9.3-r1.ebuild')
-rw-r--r--x11-misc/grun/grun-0.9.3-r1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/x11-misc/grun/grun-0.9.3-r1.ebuild b/x11-misc/grun/grun-0.9.3-r1.ebuild
new file mode 100644
index 000000000000..ff8bab19f5b6
--- /dev/null
+++ b/x11-misc/grun/grun-0.9.3-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit eutils
+
+DESCRIPTION="A GTK based Run dialog resembling the Windows Run dialog, just like xexec"
+HOMEPAGE="https://github.com/lrgc/grun"
+SRC_URI="https://grun.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~x86-fbsd"
+IUSE="nls"
+
+RDEPEND="
+ dev-libs/glib:2
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+:2
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )
+"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-no_nls.patch
+}
+
+src_configure() {
+ [[ -z ${TERM} ]] && TERM=xterm
+
+ econf \
+ $(use_enable nls) \
+ --disable-gtktest \
+ --enable-associations \
+ --enable-testfile \
+ --with-default-xterm=${TERM}
+}
+
+src_install() {
+ default
+ dodoc AUTHORS BUGS ChangeLog NEWS README TODO
+}