summaryrefslogtreecommitdiff
path: root/x11-misc/grabc/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-16 17:51:01 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-16 17:51:01 +0100
commitd83532aee7e94505bf23da29e6224ca164aac759 (patch)
treefcd6dbea91816dd541b6c602b5fed02ca574a5f6 /x11-misc/grabc/files
parenta2844b413d00a2859401e017a0311986151e1594 (diff)
gentoo auto-resync : 16:04:2023 - 17:51:01
Diffstat (limited to 'x11-misc/grabc/files')
-rw-r--r--x11-misc/grabc/files/grabc-1.1-makefile.patch28
1 files changed, 13 insertions, 15 deletions
diff --git a/x11-misc/grabc/files/grabc-1.1-makefile.patch b/x11-misc/grabc/files/grabc-1.1-makefile.patch
index ef2968ba0e14..80961ab40a04 100644
--- a/x11-misc/grabc/files/grabc-1.1-makefile.patch
+++ b/x11-misc/grabc/files/grabc-1.1-makefile.patch
@@ -1,6 +1,6 @@
--- a/Makefile
+++ b/Makefile
-@@ -2,17 +2,15 @@
+@@ -2,30 +2,16 @@
# Makefile automatically generated by genmake 1.0, Mar-16-97
# genmake 1.0 by ma_muquit@fccc.edu, RCS
##
@@ -8,30 +8,28 @@
DEFS=
PROGNAME= grabc
-LIBS= -L/usr/X11R6/lib -lX11
-+LIBS= $(shell ${PKG_CONFIG} --libs x11)
++LDLIBS= $(shell $(PKG_CONFIG) --libs x11)
INCLUDES= -I.
-# replace -O with -g in order to debug
-+# replace -O2 -pipe -Wall -march=athlon-xp with -g in order to debug
- DEFINES= $(INCLUDES) $(DEFS) -D__USE_FIXED_PROTOTYPES__ -DSYS_UNIX=1
+-DEFINES= $(INCLUDES) $(DEFS) -D__USE_FIXED_PROTOTYPES__ -DSYS_UNIX=1
-CFLAGS= -O $(DEFINES)
-
- SRCS = grabc.c
-
-@@ -20,12 +18,12 @@
-
- .c.o:
- rm -f $@
+-
+-SRCS = grabc.c
+-
+-OBJS = grabc.o
+-
+-.c.o:
+- rm -f $@
- $(CC) $(CFLAGS) -c $*.c
-+ $(CC) $(CFLAGS) $(DEFINES) -c $*.c
++CPPFLAGS += $(INCLUDES) $(DEFS) -D__USE_FIXED_PROTOTYPES__ -DSYS_UNIX=1
all: $(PROGNAME)
- $(PROGNAME) : $(OBJS)
+-$(PROGNAME) : $(OBJS)
- $(CC) $(CFLAGS) -o $(PROGNAME) $(OBJS) $(LIBS)
-+ $(CC) $(CFLAGS) $(LDFLAGS) -o $(PROGNAME) $(OBJS) $(LIBS)
-
+-
clean:
rm -f $(OBJS) $(PROGNAME) core