summaryrefslogtreecommitdiff
path: root/x11-misc/gmrun/gmrun-1.4w-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-07 21:14:14 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-07 21:14:14 +0000
commit6d44cd74809cea5f81bf52ff9cd0aa902d6b6866 (patch)
tree4045142b80c7e0479c627a84e3f0de03e574df19 /x11-misc/gmrun/gmrun-1.4w-r1.ebuild
parent8615c518b1f1d03130f21656a1a026959bb1e9c9 (diff)
gentoo auto-resync : 07:12:2022 - 21:14:14
Diffstat (limited to 'x11-misc/gmrun/gmrun-1.4w-r1.ebuild')
-rw-r--r--x11-misc/gmrun/gmrun-1.4w-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/x11-misc/gmrun/gmrun-1.4w-r1.ebuild b/x11-misc/gmrun/gmrun-1.4w-r1.ebuild
new file mode 100644
index 000000000000..7f630b5887ad
--- /dev/null
+++ b/x11-misc/gmrun/gmrun-1.4w-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/WdesktopX/${PN}.git"
+ EGIT_BRANCH="master"
+else
+ SRC_URI="https://github.com/wdlkmpx/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="amd64 ~mips ppc x86"
+fi
+
+DESCRIPTION="A GTK-2 based launcher box with bash style auto completion!"
+HOMEPAGE="https://github.com/wdlkmpx/gmrun"
+
+LICENSE="ISC"
+SLOT="0"
+IUSE="nls xdg"
+
+RDEPEND="x11-libs/gtk+:3"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_configure() {
+ econf \
+ --disable-gtk2 \
+ $(use_enable nls) \
+ $(use_enable xdg)
+}