summaryrefslogtreecommitdiff
path: root/x11-misc/gbase/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /x11-misc/gbase/files
reinit the tree, so we can have metadata
Diffstat (limited to 'x11-misc/gbase/files')
-rw-r--r--x11-misc/gbase/files/gbase-0.5-gtk.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/x11-misc/gbase/files/gbase-0.5-gtk.patch b/x11-misc/gbase/files/gbase-0.5-gtk.patch
new file mode 100644
index 000000000000..38936e79738c
--- /dev/null
+++ b/x11-misc/gbase/files/gbase-0.5-gtk.patch
@@ -0,0 +1,26 @@
+diff -ur gbase-0.5.orig/Makefile gbase-0.5/Makefile
+--- gbase-0.5.orig/Makefile 1999-10-28 00:23:51.000000000 +0300
++++ gbase-0.5/Makefile 2008-01-16 14:24:55.000000000 +0200
+@@ -1,15 +1,15 @@
+-CC = gcc
+-CCFLAGS = `gtk-config --cflags`
+-LDFLAGS = `gtk-config --libs`
++CC ?= gcc
++CFLAGS += `pkg-config --cflags gtk+-2.0`
++LIBS = `pkg-config --libs gtk+-2.0`
+
+ gbase: gbase.o
+- $(CC) gbase.o $(LDFLAGS) -o gbase
++ $(CC) $(LDFLAGS) gbase.o $(LIBS) -o gbase
+
+ clean:
+ rm -f gbase gbase.o gbase.c~
+
+ # Make object files:
+ %.o:
+- $(CC) $(CCFLAGS) -c $*.c
++ $(CC) $(CFLAGS) -c $*.c
+
+-gbase.o: gbase.c
+\ No newline at end of file
++gbase.o: gbase.c