summaryrefslogtreecommitdiff
path: root/x11-misc/dunst/dunst-1.4.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-10-13 22:19:36 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-10-14 23:22:23 +0100
commit4b19be30aa626b327c885dae62c559ec0e9fb935 (patch)
tree76e74807bc479502e13866b581b6bf86734ec634 /x11-misc/dunst/dunst-1.4.1.ebuild
parent30d6f67c98d149508509d5e86f176d558793acc0 (diff)
gentoo resync : 13.10.2019
Diffstat (limited to 'x11-misc/dunst/dunst-1.4.1.ebuild')
-rw-r--r--x11-misc/dunst/dunst-1.4.1.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/x11-misc/dunst/dunst-1.4.1.ebuild b/x11-misc/dunst/dunst-1.4.1.ebuild
new file mode 100644
index 000000000000..b4cd7451bb5a
--- /dev/null
+++ b/x11-misc/dunst/dunst-1.4.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs
+
+DESCRIPTION="Customizable and lightweight notification-daemon"
+HOMEPAGE="http://www.knopwob.org/dunst/ https://github.com/dunst-project/dunst"
+SRC_URI="https://github.com/${PN}-project/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="dunstify"
+
+CDEPEND="
+ dev-libs/glib:2
+ sys-apps/dbus
+ x11-libs/cairo[X,glib]
+ x11-libs/gdk-pixbuf
+ x11-libs/libX11
+ x11-libs/libXScrnSaver
+ x11-libs/libXinerama
+ x11-libs/libXrandr
+ x11-libs/pango[X]
+ dunstify? ( x11-libs/libnotify )
+"
+DEPEND="
+ ${CDEPEND}
+ dev-lang/perl
+ virtual/pkgconfig
+"
+RDEPEND="${CDEPEND}"
+
+src_prepare() {
+ sed -i -e "/^CFLAGS/ { s:-g::;s:-O.:: }" config.mk || die
+
+ default
+}
+
+src_compile() {
+ tc-export CC
+ emake
+ use dunstify && emake dunstify
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="/usr" install
+
+ use dunstify && dobin dunstify
+
+ dodoc AUTHORS CHANGELOG.md README.md RELEASE_NOTES
+}