summaryrefslogtreecommitdiff
path: root/x11-misc/dex/dex-0.9.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-01 17:20:35 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-01 17:20:35 +0100
commita88eb1d9b7042912d196e255eeb20e0c77f6cf47 (patch)
tree291cc788e33b3de8bf1b5e3f1fdddf315f2f5ee7 /x11-misc/dex/dex-0.9.0.ebuild
parentc3d14fe9accdf0b091e42f26a66ed7626ba8c24b (diff)
gentoo auto-resync : 01:05:2023 - 17:20:35
Diffstat (limited to 'x11-misc/dex/dex-0.9.0.ebuild')
-rw-r--r--x11-misc/dex/dex-0.9.0.ebuild22
1 files changed, 16 insertions, 6 deletions
diff --git a/x11-misc/dex/dex-0.9.0.ebuild b/x11-misc/dex/dex-0.9.0.ebuild
index 9a26bc92b006..4774c80d2f54 100644
--- a/x11-misc/dex/dex-0.9.0.ebuild
+++ b/x11-misc/dex/dex-0.9.0.ebuild
@@ -3,8 +3,7 @@
EAPI=8
-PYTHON_COMPAT=( python3_{9..10} )
-
+PYTHON_COMPAT=( python3_{9..11} )
inherit python-r1
DESCRIPTION="DesktopEntry eXecution - tool to manage and launch autostart entries"
@@ -14,20 +13,31 @@ SRC_URI="https://github.com/jceb/dex/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-
IUSE="doc"
-
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+# https://github.com/jceb/dex/issues/37
+RESTRICT="test"
RDEPEND="${PYTHON_DEPS}"
-DEPEND="${RDEPEND}
- doc? ( dev-python/sphinx )"
+DEPEND="${RDEPEND}"
+BDEPEND="doc? ( dev-python/sphinx )"
src_compile() {
# Makefile is for creating man page only
use doc && emake
}
+src_test() {
+ dex_test() {
+ ./dex --test 2>&1 | tee test.log || die
+ if grep -q "Failed example" test.log ; then
+ die "Tests failed with ${EPYTHON}"
+ fi
+ }
+
+ python_foreach_impl dex_test
+}
+
src_install() {
dobin dex
python_replicate_script "${ED}/usr/bin/dex"