summaryrefslogtreecommitdiff
path: root/x11-misc/dex/dex-0.9.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-01-04 01:27:12 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-01-04 01:27:12 +0000
commit3517852e3b8a68d1e997770fc0650c5053bafc6c (patch)
tree44068672445b1418489aed82de58df3c470289e7 /x11-misc/dex/dex-0.9.0.ebuild
parent0f15659d48c193027158492acb726297501202c5 (diff)
gentoo resync : 04.01.2022
Diffstat (limited to 'x11-misc/dex/dex-0.9.0.ebuild')
-rw-r--r--x11-misc/dex/dex-0.9.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/x11-misc/dex/dex-0.9.0.ebuild b/x11-misc/dex/dex-0.9.0.ebuild
new file mode 100644
index 000000000000..191bf3097bcb
--- /dev/null
+++ b/x11-misc/dex/dex-0.9.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit python-r1
+
+DESCRIPTION="DesktopEntry eXecution - tool to manage and launch autostart entries"
+HOMEPAGE="http://e-jc.de/"
+SRC_URI="https://github.com/jceb/dex/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+IUSE="doc"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}"
+DEPEND="${RDEPEND}
+ doc? ( dev-python/sphinx )"
+
+src_compile() {
+ # Makefile is for creating man page only
+ use doc && emake
+}
+
+src_install() {
+ dobin dex
+ python_replicate_script "${ED}/usr/bin/dex"
+ dodoc CHANGELOG.md README.rst
+ use doc && doman dex.1
+}