summaryrefslogtreecommitdiff
path: root/x11-misc/devilspie2/devilspie2-0.43-r100.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-12-14 13:26:14 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-12-14 13:26:14 +0000
commit6abbf81ef2f298e3221ff5e67a1f3c5f23958212 (patch)
tree25413d1cb3a0cbfe36029db32398c0f333609215 /x11-misc/devilspie2/devilspie2-0.43-r100.ebuild
parent9c417bacd51da6d8b57fa9f37425161d30d4b95b (diff)
gentoo resync : 14.12.2020
Diffstat (limited to 'x11-misc/devilspie2/devilspie2-0.43-r100.ebuild')
-rw-r--r--x11-misc/devilspie2/devilspie2-0.43-r100.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/x11-misc/devilspie2/devilspie2-0.43-r100.ebuild b/x11-misc/devilspie2/devilspie2-0.43-r100.ebuild
new file mode 100644
index 000000000000..e9c87f823d33
--- /dev/null
+++ b/x11-misc/devilspie2/devilspie2-0.43-r100.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+LUA_COMPAT=( lua5-{1..3} luajit )
+PLOCALES="fi fr it ja nl pt_BR ru sv"
+
+inherit lua-single toolchain-funcs l10n
+
+DESCRIPTION="Devilspie like window matching utility, using LUA for scripting"
+HOMEPAGE="https://www.nongnu.org/devilspie2/"
+SRC_URI="https://download.savannah.gnu.org/releases/devilspie2/devilspie2_${PV}-src.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+
+RDEPEND="
+ ${LUA_DEPS}
+ >=dev-libs/glib-2.32.4:2
+ >=x11-libs/gtk+-3.4.4:3
+ >=x11-libs/libwnck-3.4.4:3
+ x11-libs/libX11
+"
+DEPEND="
+ ${RDEPEND}
+ x11-base/xorg-proto
+"
+BDEPEND="
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.43-lua-pkgconfig.patch"
+)
+
+src_compile() {
+ emake CC="$(tc-getCC)" PREFIX="/usr" LANGUAGES="$(l10n_get_locales)"
+}
+
+src_install() {
+ emake PREFIX="/usr" DESTDIR="${ED}" LANGUAGES="$(l10n_get_locales)" install
+ einstalldocs
+ doman devilspie2.1
+}