summaryrefslogtreecommitdiff
path: root/x11-misc/devilspie2/devilspie2-0.42.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /x11-misc/devilspie2/devilspie2-0.42.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'x11-misc/devilspie2/devilspie2-0.42.ebuild')
-rw-r--r--x11-misc/devilspie2/devilspie2-0.42.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/x11-misc/devilspie2/devilspie2-0.42.ebuild b/x11-misc/devilspie2/devilspie2-0.42.ebuild
new file mode 100644
index 000000000000..ad543d5081a1
--- /dev/null
+++ b/x11-misc/devilspie2/devilspie2-0.42.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# check locales on version bump!
+PLOCALES="fi fr it ja nl pt_BR ru sv"
+inherit flag-o-matic toolchain-funcs l10n
+
+DESCRIPTION="Devilspie like window matching utility, using LUA for scripting"
+HOMEPAGE="https://gusnan.se/devilspie2"
+SRC_URI="http://download.savannah.gnu.org/releases/devilspie2/devilspie2_${PV}-src.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="debug"
+
+RDEPEND="
+ >=dev-lang/lua-5.1.5:0
+ >=dev-libs/glib-2.32.4:2
+ >=x11-libs/gtk+-3.4.4:3
+ >=x11-libs/libwnck-3.4.4:3
+ x11-libs/libX11
+"
+DEPEND="
+ ${RDEPEND}
+ sys-devel/gettext
+ virtual/pkgconfig
+ x11-proto/xproto
+"
+
+src_prepare() {
+ default
+ use debug && append-cflags -D_DEBUG
+}
+
+src_compile() {
+ emake CC=$(tc-getCC) PREFIX="/usr" LANGUAGES="$(l10n_get_locales)"
+}
+
+src_install() {
+ emake PREFIX="/usr" DESTDIR="${D}" LANGUAGES="$(l10n_get_locales)" install
+
+ dodoc AUTHORS ChangeLog README README.translators TODO VERSION
+ doman devilspie2.1
+}
+
+pkg_postinst() {
+ elog "Default directory for scripts is ~/.config/devilspie2/"
+}