summaryrefslogtreecommitdiff
path: root/x11-misc/compton
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-21 17:50:24 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-21 17:50:24 +0100
commitfeb0daf81d888e9160f9f94502de09b66f2a63fd (patch)
treeb6e5c40ce2abef3da27ed50a023153f475e0ddef /x11-misc/compton
parent9452a6e87b6c2c70513bc47a2470bf9f1168920e (diff)
gentoo resync : 21.06.2020
Diffstat (limited to 'x11-misc/compton')
-rw-r--r--x11-misc/compton/Manifest1
-rw-r--r--x11-misc/compton/compton-0.1_beta2-r1.ebuild69
2 files changed, 70 insertions, 0 deletions
diff --git a/x11-misc/compton/Manifest b/x11-misc/compton/Manifest
index 0e5318dc922b..f2a548b81aea 100644
--- a/x11-misc/compton/Manifest
+++ b/x11-misc/compton/Manifest
@@ -1,3 +1,4 @@
DIST compton-0.1_beta2.tar.gz 144239 BLAKE2B 993c091aa0eab4171740a26c4ea8e9da66368fbcddbbdf9c466dd2cb2dbe0a685dc6c2027a5b56d08df4fd42d21784dd2cbb7cf56869feb1b74b4854db20a5f8 SHA512 c3a019d90e32559d44e3a4969bcc15a15837db9c9519ce8cc70b1bd3d0cb16d29449f68cc2f6a8d834569c9620ec6533ab85c1586da957c69b1ae341d9584535
+EBUILD compton-0.1_beta2-r1.ebuild 1622 BLAKE2B bc94eb7180dc20d20d20cdc8dbc85180ebfe2b94ef73637b215fbd8c138bcaddf6c0f87db7417710e73f46b9bea8631e04d958775306deabc5ee69860fa13fb1 SHA512 eb576faf20ff968a86bfe6a09530b7284870e31eab7eac31185ff34f07c8e6cadccdb4fde039556c77bf72fd7b588b8ab58984d78938862a29961dce9153d0e4
EBUILD compton-0.1_beta2.ebuild 1612 BLAKE2B c2bb025332d6e10ad0b8e9f862b2276f70d9ba8ff4001659a961424859d3615837e40be4c1da718f2c7d710760a227a18260c6cadadbcf21efe8c43dabdb01ce SHA512 9602222cc536892d0f1538b59bb768b379f093eb45641fb362f28ff5013dee6e8715039f0256ef075706998871ce06bdb9673d9edf748abb1004926aa1a5cf5c
MISC metadata.xml 484 BLAKE2B 903744ba49b9aaae86cec59c83f96f02da325d17813d6ceaedd88eab1450ae76eac7a40c9e1b44086651efd21e5580b605b9095925625fa3bb1e6c708ed8809f SHA512 d01d17901f47f7e2c0201c0a6665d0e27693ac42b27ef8dce8a78763ec775a41fed88b4565db434351a2c9d01e762121bca3f347f467e77e71bde66f019640cb
diff --git a/x11-misc/compton/compton-0.1_beta2-r1.ebuild b/x11-misc/compton/compton-0.1_beta2-r1.ebuild
new file mode 100644
index 000000000000..1b4cdd3e8453
--- /dev/null
+++ b/x11-misc/compton/compton-0.1_beta2-r1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+inherit toolchain-funcs python-r1
+
+DESCRIPTION="A compositor for X, and a fork of xcompmgr-dana"
+HOMEPAGE="https://github.com/chjj/compton"
+SRC_URI="https://github.com/chjj/compton/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="dbus +drm opengl +pcre xinerama"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+COMMON_DEPEND="${PYTHON_DEPS}
+ dev-libs/libconfig:=
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ dbus? ( sys-apps/dbus )
+ opengl? ( virtual/opengl )
+ pcre? ( dev-libs/libpcre:3 )
+ xinerama? ( x11-libs/libXinerama )"
+RDEPEND="${COMMON_DEPEND}
+ x11-apps/xprop
+ x11-apps/xwininfo"
+DEPEND="${COMMON_DEPEND}
+ app-text/asciidoc
+ virtual/pkgconfig
+ x11-base/xorg-proto
+ drm? ( x11-libs/libdrm )"
+
+nobuildit() { use $1 || echo yes ; }
+
+pkg_setup() {
+ if [[ ${MERGE_TYPE} != binary ]]; then
+ tc-export CC
+ fi
+}
+
+src_compile() {
+ emake docs
+
+ NO_DBUS=$(nobuildit dbus) \
+ NO_XINERAMA=$(nobuildit xinerama) \
+ NO_VSYNC_DRM=$(nobuildit drm) \
+ NO_VSYNC_OPENGL=$(nobuildit opengl) \
+ NO_REGEX_PCRE=$(nobuildit pcre) \
+ emake compton
+}
+
+src_install() {
+ NO_DBUS=$(nobuildit dbus) \
+ NO_VSYNC_DRM=$(nobuildit drm) \
+ NO_VSYNC_OPENGL=$(nobuildit opengl) \
+ NO_REGEX_PCRE=$(nobuildit pcre) \
+ default
+ docinto examples
+ dodoc compton.sample.conf dbus-examples/*
+ python_foreach_impl python_newscript bin/compton-convgen.py compton-convgen
+}