summaryrefslogtreecommitdiff
path: root/x11-misc/compose-tables
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
commite68d405c5d712af4387159df07e226217bdda049 (patch)
tree009ab0f3d427f0813e62930d71802cb054c07e30 /x11-misc/compose-tables
parent401101f9c8077911929d3f2b60a37098460a5d89 (diff)
gentoo resync : 06.04.2022
Diffstat (limited to 'x11-misc/compose-tables')
-rw-r--r--x11-misc/compose-tables/Manifest4
-rw-r--r--x11-misc/compose-tables/compose-tables-1.7.4.ebuild42
-rw-r--r--x11-misc/compose-tables/compose-tables-1.7.5.ebuild42
3 files changed, 88 insertions, 0 deletions
diff --git a/x11-misc/compose-tables/Manifest b/x11-misc/compose-tables/Manifest
index e6f4ed79c789..375c0cb6c066 100644
--- a/x11-misc/compose-tables/Manifest
+++ b/x11-misc/compose-tables/Manifest
@@ -1,3 +1,7 @@
DIST libX11-1.7.3.tar.xz 1861304 BLAKE2B e0f647ef55567b1d7eff74bc053b8e73f8c696be6f233c2ff6f64dee65c1b40b746683ea7a6fafb4304eba4dec43301b4b3506e2ec6fac1d4c89d664b516bbdd SHA512 abc70837d19f7e104a5db1e6d2cfa1256625332c0b53fec44a0a39916a60a430bb53fd436207892aabe4199ac7a0f9287a06588fcd27e0eed54d45d67bbe1294
+DIST libX11-1.7.4.tar.xz 1872992 BLAKE2B 6a25e5008ead53be5af7411f51711789eb410473f9aefc49fb4d0bf7227b89c5fd71f0f61fef9bc3f83e585e4815644f42884d5e5cf0bdcdd120abe6fe8a741b SHA512 8bfaaf9fc3081c47152d533d30cdc0b2521bfeb088ff813b041c08ffd518c80ba3725bb68cac7c21b521a4bace546f99424700fe21955b498015d14c2f7f9a57
+DIST libX11-1.7.5.tar.xz 1853152 BLAKE2B 95ceccbfd37d8a749a533bdc03feba94236a47185a2cd7ad6592c534c17636906b735aa5800d810d13d3e342e3dbe281bb1f1f3ecab9d07e6a6a50f33beef8af SHA512 ef33e2f631226cab27657f46e1fd4cfc928f62f928d8297474e7b993017c8f92b60272eed6515990cdf3a9d34581837b7a3896e584f3546dd26f3790034df347
EBUILD compose-tables-1.7.3.ebuild 943 BLAKE2B 859cec003f23b043e2271eab3aa31a01ee8ff66a7a78749ced99ff98d09eeb085497fe799138d5efa2a30f83f1097305a90ffa7caccf47bffbdfed72faa29e48 SHA512 2355bba44c7af1937aea4cc68248a96e38f9fd6188d85da7a755e344f4e3add63ae19db03409703b103ebb5045401b621a4258866ead6c79fbd1fb78f9e1e9a4
+EBUILD compose-tables-1.7.4.ebuild 951 BLAKE2B 450f86acb64044d49f6fd21d92a70a3997fd5fe96105aa2676de65737086d982f9a139764e6cbe32e9e0379ae5deca0a17f6e455c5129ed2db6b1c3756ee71ee SHA512 da3d0b1217ef9a2d7f786e99001de745659d5aba01cd9e4d316116972d411abedabf006f1020437b6657c188162088d5b4f02a2c1074e1c736b3fd51bb25c610
+EBUILD compose-tables-1.7.5.ebuild 951 BLAKE2B 450f86acb64044d49f6fd21d92a70a3997fd5fe96105aa2676de65737086d982f9a139764e6cbe32e9e0379ae5deca0a17f6e455c5129ed2db6b1c3756ee71ee SHA512 da3d0b1217ef9a2d7f786e99001de745659d5aba01cd9e4d316116972d411abedabf006f1020437b6657c188162088d5b4f02a2c1074e1c736b3fd51bb25c610
MISC metadata.xml 312 BLAKE2B 297d68d5585ee7fe053a0b9d1e4758d1c8538fbfa6037cddfefa84f5b757c1c768d4ab072f6198e19c1b9bf4d21120440db61e5a9690cc6cfd387ee9d2add736 SHA512 4b5fc7ba8a7c24241e7ab5dd68677ccba15f5e89a76482679f18139faea4ff1555759066041afbf51c65d1870ec0d999a772c340f1e934a6aba0135b8da28d18
diff --git a/x11-misc/compose-tables/compose-tables-1.7.4.ebuild b/x11-misc/compose-tables/compose-tables-1.7.4.ebuild
new file mode 100644
index 000000000000..4cdfc490b634
--- /dev/null
+++ b/x11-misc/compose-tables/compose-tables-1.7.4.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+XORG_MULTILIB=no
+XORG_TARBALL_SUFFIX=xz
+inherit xorg-3
+
+# Note: please bump this with x11-libs/libX11
+DESCRIPTION="X.Org Compose Key tables from libX11"
+# xorg-3.eclass would attempt to fetch a tarball with a matching name to this package
+SRC_URI="${XORG_BASE_INDIVIDUAL_URI}/lib/libX11-${PV}.tar.${XORG_TARBALL_SUFFIX}"
+S="${WORKDIR}/libX11-${PV}/"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+
+# Only needed by configure
+DEPEND="
+ x11-base/xorg-proto
+ >=x11-libs/libxcb-1.11.1
+ x11-libs/xtrans"
+RDEPEND="!<x11-libs/libX11-1.7.0"
+
+XORG_CONFIGURE_OPTIONS=(
+ --without-xmlto
+ --without-fop
+ --disable-specs
+ --disable-xkb
+)
+
+src_compile() {
+ emake -C nls
+}
+
+src_test() {
+ :;
+}
+
+src_install() {
+ emake DESTDIR="${D}" -C nls install
+}
diff --git a/x11-misc/compose-tables/compose-tables-1.7.5.ebuild b/x11-misc/compose-tables/compose-tables-1.7.5.ebuild
new file mode 100644
index 000000000000..4cdfc490b634
--- /dev/null
+++ b/x11-misc/compose-tables/compose-tables-1.7.5.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+XORG_MULTILIB=no
+XORG_TARBALL_SUFFIX=xz
+inherit xorg-3
+
+# Note: please bump this with x11-libs/libX11
+DESCRIPTION="X.Org Compose Key tables from libX11"
+# xorg-3.eclass would attempt to fetch a tarball with a matching name to this package
+SRC_URI="${XORG_BASE_INDIVIDUAL_URI}/lib/libX11-${PV}.tar.${XORG_TARBALL_SUFFIX}"
+S="${WORKDIR}/libX11-${PV}/"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+
+# Only needed by configure
+DEPEND="
+ x11-base/xorg-proto
+ >=x11-libs/libxcb-1.11.1
+ x11-libs/xtrans"
+RDEPEND="!<x11-libs/libX11-1.7.0"
+
+XORG_CONFIGURE_OPTIONS=(
+ --without-xmlto
+ --without-fop
+ --disable-specs
+ --disable-xkb
+)
+
+src_compile() {
+ emake -C nls
+}
+
+src_test() {
+ :;
+}
+
+src_install() {
+ emake DESTDIR="${D}" -C nls install
+}