summaryrefslogtreecommitdiff
path: root/x11-misc/compose-tables
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-05 21:17:55 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-05 21:17:55 +0000
commit519f4aac6d5896fe0204e6429485f95240c7ff58 (patch)
tree467adac90d818b96465a433b66ef6bb65e369fef /x11-misc/compose-tables
parent8afe4133ba3d8586301516885427809020a3cafa (diff)
gentoo auto-resync : 05:02:2023 - 21:17:55
Diffstat (limited to 'x11-misc/compose-tables')
-rw-r--r--x11-misc/compose-tables/Manifest2
-rw-r--r--x11-misc/compose-tables/compose-tables-1.8.4.ebuild42
2 files changed, 44 insertions, 0 deletions
diff --git a/x11-misc/compose-tables/Manifest b/x11-misc/compose-tables/Manifest
index a46be03fd4f1..5c324a0fb88e 100644
--- a/x11-misc/compose-tables/Manifest
+++ b/x11-misc/compose-tables/Manifest
@@ -1,3 +1,5 @@
DIST libX11-1.8.3.tar.xz 1811712 BLAKE2B 0adc92c13ba4bdec5d927349ca8c02adbb851eb376f19aa5f39e13caddb36c089be227c1f2dc61b34f882aae794f2b46ae237345c12c8e897be8df01e9fb3ef2 SHA512 bc862338fed855986659e9ffa641db6b36c3ac9abced590d1b164e3cc24446671936e3688cdca18393129c4ea41777977eeb37e87d8edc14d6cc5d194a9c0325
+DIST libX11-1.8.4.tar.xz 1835316 BLAKE2B f9f5d1b97e8ac6f8f0edc490a270f98ff4fd901c2054c309bce1f1b3eb690704193e18cd470f682c663090210b14a9498b9259b6acc0e902053e7ab0ca9df076 SHA512 3150a47498b0cb012482ee02efeaae16d9e736288f2b3f917be912e1613d56ad6b4ab180de8820305deb2b95dfd993633f43a65344d75979d6b86bdf110cb63e
EBUILD compose-tables-1.8.3.ebuild 950 BLAKE2B 8f1e0b0e2a697c5afb72e8bee632227d8ea8d72275f42c38063a8e7b72571e62722bb7317deb7d488027cf85e792a34949933b9b47c3fdec1b63f8dd39ed2d40 SHA512 15b24815e8d5aa31e9282807ffa8233d6c4b7eab2bfde298c8c47c22c7adc6d64c46abfbdfc09f06501459eb53313fa911b52082e2fce5c964b356fda6903989
+EBUILD compose-tables-1.8.4.ebuild 935 BLAKE2B 426caae4852a71e3d5e6738e22d2c88f4eb0ee924c83ae929c2f9ae1be9fee5d986cec52367bb168d60c3b67e89986b103133360e64a1be866c8907ea2e4e1ef SHA512 cb47a8a5efed67a9d0dc079f679109a52a0bd6d8cb724ed9f3eece87c41adede4c70a68065bf588cc0fd9419284a2986959ceb365a626a5dfadef0463551c63d
MISC metadata.xml 395 BLAKE2B 7912fcccfd8d8a4c9c1e5601783a0668679506638511ee719bf7bb95f99415fe95a417343060cf5ca3fe918ab1f9847f74861af36d3c712afa321272cd13cf66 SHA512 c2956ef519fe59d0f713732059224568b9d7c34579654b71993b02227a512c1ac3057dc7f81c6bc93834fd4fee212f1ae26f4055ea92f3eb7524da7d9e690f8f
diff --git a/x11-misc/compose-tables/compose-tables-1.8.4.ebuild b/x11-misc/compose-tables/compose-tables-1.8.4.ebuild
new file mode 100644
index 000000000000..3b4c2859cf16
--- /dev/null
+++ b/x11-misc/compose-tables/compose-tables-1.8.4.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+XORG_MULTILIB=no
+XORG_TARBALL_SUFFIX=xz
+inherit xorg-3
+
+# Note: please bump this with x11-libs/libX11
+DESCRIPTION="X.Org Compose Key tables from libX11"
+# xorg-3.eclass would attempt to fetch a tarball with a matching name to this package
+SRC_URI="${XORG_BASE_INDIVIDUAL_URI}/lib/libX11-${PV}.tar.${XORG_TARBALL_SUFFIX}"
+S="${WORKDIR}/libX11-${PV}/"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+
+# Only needed by configure
+DEPEND="
+ x11-base/xorg-proto
+ >=x11-libs/libxcb-1.11.1
+ x11-libs/xtrans"
+RDEPEND=""
+
+XORG_CONFIGURE_OPTIONS=(
+ --without-xmlto
+ --without-fop
+ --disable-specs
+ --disable-xkb
+)
+
+src_compile() {
+ emake -C nls
+}
+
+src_test() {
+ :;
+}
+
+src_install() {
+ emake DESTDIR="${D}" -C nls install
+}