summaryrefslogtreecommitdiff
path: root/x11-misc/chgres/files/chgres-0.1-flags.patch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /x11-misc/chgres/files/chgres-0.1-flags.patch
reinit the tree, so we can have metadata
Diffstat (limited to 'x11-misc/chgres/files/chgres-0.1-flags.patch')
-rw-r--r--x11-misc/chgres/files/chgres-0.1-flags.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/x11-misc/chgres/files/chgres-0.1-flags.patch b/x11-misc/chgres/files/chgres-0.1-flags.patch
new file mode 100644
index 000000000000..4045175dde09
--- /dev/null
+++ b/x11-misc/chgres/files/chgres-0.1-flags.patch
@@ -0,0 +1,21 @@
+--- a/Makefile 2001-04-18 23:07:56.000000000 +0200
++++ b/Makefile 2010-09-17 03:08:55.000000000 +0200
+@@ -1,9 +1,9 @@
+-CFLAGS=
+-LDFLAGS= -L/usr/X11R6/lib -lXext -lX11 -lXxf86vm -lXxf86dga
++LIBS= $(shell pkg-config --libs xext x11 xxf86vm xxf86dga)
++INCLUDES= $(shell pkg-config --cflags xext x11 xxf86vm xxf86dga)
+ prefix=/usr
+
+ chgres: chgres.o
+- $(CC) -o $@ $< $(LDFLAGS)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $< $(LIBS)
+
+ install: chgres
+ install -D -m 0555 chgres $(prefix)/bin/
+@@ -12,4 +12,4 @@
+ rm -f core chgres.o chgres
+
+ .c.o:
+- $(CC) $(CFLAGS) -c $< -o $@
++ $(CC) $(CFLAGS) $(INCLUDES) -c $< -o $@