summaryrefslogtreecommitdiff
path: root/x11-misc/bbtime/bbtime-0.1.5-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-01-16 20:27:28 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-01-16 20:27:28 +0000
commit2fd57282f0262ca084e05b0f2c63fbada395d02b (patch)
tree4e0f23cea9ce9fd972e70ebc5214bf36fed465cc /x11-misc/bbtime/bbtime-0.1.5-r2.ebuild
parentc3bc61051d7f12b4c682efa7a5460bbc8815649e (diff)
gentoo resync : 16.01.2021
Diffstat (limited to 'x11-misc/bbtime/bbtime-0.1.5-r2.ebuild')
-rw-r--r--x11-misc/bbtime/bbtime-0.1.5-r2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/x11-misc/bbtime/bbtime-0.1.5-r2.ebuild b/x11-misc/bbtime/bbtime-0.1.5-r2.ebuild
new file mode 100644
index 000000000000..41b5aca4de1c
--- /dev/null
+++ b/x11-misc/bbtime/bbtime-0.1.5-r2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="blackbox time watcher"
+HOMEPAGE="https://sourceforge.net/projects/bbtools/"
+SRC_URI="mirror://sourceforge/bbtools/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11"
+DEPEND="${RDEPEND}"
+
+DOCS=( README AUTHORS BUGS ChangeLog NEWS TODO data/README.bbtime )
+PATCHES=( "${FILESDIR}"/${P}-asneeded.patch )
+
+src_prepare() {
+ default
+ mv configure.{in,ac} || die
+ eautoreconf
+}
+
+src_install() {
+ default
+ rm "${ED}"/usr/share/bbtools/README.bbtime || die
+ # since multiple bbtools packages provide this file, install
+ # it in /usr/share/doc/${PF}
+ mv "${ED}/usr/share/bbtools/bbtoolsrc.in" \
+ "${ED}/usr/share/doc/${PF}/bbtoolsrc.example" || die
+}