summaryrefslogtreecommitdiff
path: root/x11-misc/bbppp/bbppp-0.2.5-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /x11-misc/bbppp/bbppp-0.2.5-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'x11-misc/bbppp/bbppp-0.2.5-r1.ebuild')
-rw-r--r--x11-misc/bbppp/bbppp-0.2.5-r1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/x11-misc/bbppp/bbppp-0.2.5-r1.ebuild b/x11-misc/bbppp/bbppp-0.2.5-r1.ebuild
new file mode 100644
index 000000000000..9845508cd8a5
--- /dev/null
+++ b/x11-misc/bbppp/bbppp-0.2.5-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+
+inherit autotools eutils
+
+DESCRIPTION="blackbox ppp frontend/monitor"
+HOMEPAGE="https://sourceforge.net/projects/bbtools/"
+SRC_URI="mirror://sourceforge/bbtools/${PN}/${P}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="x11-libs/libX11"
+RDEPEND="${DEPEND}
+ media-fonts/font-adobe-100dpi"
+
+DOCS=( README AUTHORS BUGS ChangeLog NEWS TODO data/README.bbppp )
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc3-multiline.patch \
+ "${FILESDIR}"/${PN}-asneeded.patch \
+ "${FILESDIR}"/${P}-overflows.patch
+ eautoreconf
+}
+
+src_install () {
+ default
+ rm "${D}"/usr/share/bbtools/README.bbppp
+}
+
+pkg_postinst() {
+ # don't assume blackbox exists because virtual/blackbox is installed
+ if [[ -x ${ROOT}/usr/bin/blackbox ]] ; then
+ if ! grep bbppp "${ROOT}"/usr/bin/blackbox &>/dev/null ; then
+ sed -e "s/.*blackbox/exec \/usr\/bin\/bbppp \&\n&/" blackbox | cat > blackbox
+ fi
+ fi
+}