summaryrefslogtreecommitdiff
path: root/x11-misc/bbcd/bbcd-0.3.1-r4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-01-16 20:27:28 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-01-16 20:27:28 +0000
commit2fd57282f0262ca084e05b0f2c63fbada395d02b (patch)
tree4e0f23cea9ce9fd972e70ebc5214bf36fed465cc /x11-misc/bbcd/bbcd-0.3.1-r4.ebuild
parentc3bc61051d7f12b4c682efa7a5460bbc8815649e (diff)
gentoo resync : 16.01.2021
Diffstat (limited to 'x11-misc/bbcd/bbcd-0.3.1-r4.ebuild')
-rw-r--r--x11-misc/bbcd/bbcd-0.3.1-r4.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/x11-misc/bbcd/bbcd-0.3.1-r4.ebuild b/x11-misc/bbcd/bbcd-0.3.1-r4.ebuild
new file mode 100644
index 000000000000..5932a96d6e09
--- /dev/null
+++ b/x11-misc/bbcd/bbcd-0.3.1-r4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic
+
+DESCRIPTION="Basic CD Player for blackbox wm"
+HOMEPAGE="http://tranber1.free.fr/bbcd.html"
+SRC_URI="http://tranber1.free.fr/${P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="media-libs/libcdaudio
+ x11-libs/libX11"
+DEPEND="${RDEPEND}
+ x11-libs/libXt"
+
+PATCHES=(
+ "${FILESDIR}"/${P}_${PV}a.diff
+ "${FILESDIR}"/${P}-gcc3.3.patch
+ "${FILESDIR}"/${P}-gcc4.3.patch
+)
+
+src_configure() {
+ append-cxxflags -std=c++14
+ default
+}
+
+src_install() {
+ default
+ rm "${ED}/usr/share/bbtools/README.bbcd" || die
+}