summaryrefslogtreecommitdiff
path: root/x11-misc/autorandr/autorandr-1.12.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-19 13:58:24 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-19 13:58:24 +0100
commit12652841746da7ae2f03b8b0c571a9bd5033e15c (patch)
tree17ba3a2b3f142284453d0e9109be1765200f643b /x11-misc/autorandr/autorandr-1.12.1-r1.ebuild
parent27f7ac2204449d9fc2137f442522b4fb10327d90 (diff)
gentoo auto-resync : 19:10:2022 - 13:58:24
Diffstat (limited to 'x11-misc/autorandr/autorandr-1.12.1-r1.ebuild')
-rw-r--r--x11-misc/autorandr/autorandr-1.12.1-r1.ebuild65
1 files changed, 65 insertions, 0 deletions
diff --git a/x11-misc/autorandr/autorandr-1.12.1-r1.ebuild b/x11-misc/autorandr/autorandr-1.12.1-r1.ebuild
new file mode 100644
index 000000000000..0badb8f708aa
--- /dev/null
+++ b/x11-misc/autorandr/autorandr-1.12.1-r1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit bash-completion-r1 distutils-r1 systemd udev
+
+if [[ "${PV}" = "9999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/phillipberndt/${PN}.git"
+else
+ SRC_URI="https://github.com/phillipberndt/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Automatically select a display configuration based on connected devices"
+HOMEPAGE="https://github.com/phillipberndt/autorandr"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="launcher systemd udev"
+
+RDEPEND="
+ x11-apps/xrandr
+ launcher? ( x11-libs/libxcb )
+ udev? ( virtual/udev )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_compile() {
+ distutils-r1_src_compile
+
+ if use launcher; then
+ emake contrib/autorandr_launcher/autorandr-launcher
+ fi
+}
+
+src_install() {
+ distutils-r1_src_install
+
+ doman autorandr.1
+
+ local targets=(
+ autostart_config
+ bash_completion
+ $(usev launcher)
+ $(usev systemd)
+ $(usev udev)
+ )
+
+ emake DESTDIR="${D}" \
+ BASH_COMPLETIONS_DIR="$(get_bashcompdir)" \
+ SYSTEMD_UNIT_DIR="$(systemd_get_systemunitdir)" \
+ UDEV_RULES_DIR="$(get_udevdir)"/rules.d \
+ $(printf "install_%s " "${targets[@]}")
+}
+
+pkg_postinst() {
+ if use udev; then
+ udev_reload
+ fi
+}