summaryrefslogtreecommitdiff
path: root/x11-misc/arandr/arandr-0.1.11.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-18 05:56:19 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-18 05:56:19 +0000
commit3b34ca9eec2676e6fe530f34e463f52308a11441 (patch)
tree851348b7aaa208dd7852f8ddeb950b6395b2e1bc /x11-misc/arandr/arandr-0.1.11.ebuild
parentb8f9cc8d0880d028eb7536742f0042580b55a72e (diff)
gentoo auto-resync : 18:01:2023 - 05:56:19
Diffstat (limited to 'x11-misc/arandr/arandr-0.1.11.ebuild')
-rw-r--r--x11-misc/arandr/arandr-0.1.11.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/x11-misc/arandr/arandr-0.1.11.ebuild b/x11-misc/arandr/arandr-0.1.11.ebuild
new file mode 100644
index 000000000000..1070e68f54ef
--- /dev/null
+++ b/x11-misc/arandr/arandr-0.1.11.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+inherit distutils-r1
+
+DESCRIPTION="Another XRandR GUI"
+HOMEPAGE="https://christian.amsuess.com/tools/arandr/"
+SRC_URI="https://christian.amsuess.com/tools/arandr/files/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+RDEPEND="
+ dev-python/pygobject:3=[${PYTHON_USEDEP},cairo]
+ x11-libs/gtk+:3[introspection]
+ x11-apps/xrandr
+"
+BDEPEND="dev-python/docutils[${PYTHON_USEDEP}]"
+
+PATCHES=( "${FILESDIR}/${PN}-0.1.10-manpages.patch" )