summaryrefslogtreecommitdiff
path: root/x11-misc/albert/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-04 22:23:05 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-04 22:23:05 +0100
commitcb259c03daeefbbc0a46d61314d25be7edeb14e8 (patch)
treee228a8c4418efcbf6d2bcf37aa9f01bd1b4eb43b /x11-misc/albert/files
parent86eece26841510c190c0b254a24efc4d6b42acec (diff)
gentoo auto-resync : 04:09:2022 - 22:23:05
Diffstat (limited to 'x11-misc/albert/files')
-rw-r--r--x11-misc/albert/files/albert-0.17.3-find-and-use-python-libraries-and-headers.patch33
1 files changed, 33 insertions, 0 deletions
diff --git a/x11-misc/albert/files/albert-0.17.3-find-and-use-python-libraries-and-headers.patch b/x11-misc/albert/files/albert-0.17.3-find-and-use-python-libraries-and-headers.patch
new file mode 100644
index 000000000000..943e5d8acf2d
--- /dev/null
+++ b/x11-misc/albert/files/albert-0.17.3-find-and-use-python-libraries-and-headers.patch
@@ -0,0 +1,33 @@
+From aa89c47db62163eddea623beb48f7ffd8d76062c Mon Sep 17 00:00:00 2001
+From: Buchan Milne <bgmilne@gmail.com>
+Date: Thu, 14 Jun 2018 08:10:31 +0200
+Subject: [PATCH] Find and use python libraries and headers
+
+---
+ plugins/python/CMakeLists.txt | 3 +++
+ 1 file changed, 3 insertions(+)
+
+diff --git a/plugins/python/CMakeLists.txt b/plugins/python/CMakeLists.txt
+index 2dd085d..0dc9b91 100644
+--- a/plugins/python/CMakeLists.txt
++++ b/plugins/python/CMakeLists.txt
+@@ -5,7 +5,8 @@ PROJECT(python)
+ FILE(GLOB_RECURSE SRC src/*)
+
+ find_package(Qt5 5.5.0 REQUIRED COMPONENTS Widgets)
+-add_subdirectory(pybind11)
++find_package(PythonLibs)
++include_directories(${PYTHON_INCLUDE_DIRS})
+
+ add_library(${PROJECT_NAME} SHARED ${SRC} ${PROJECT_NAME}.qrc metadata.json)
+
+@@ -14,8 +15,8 @@ target_include_directories(${PROJECT_NAME} PRIVATE src/)
+ target_link_libraries(${PROJECT_NAME}
+ PUBLIC
+ Qt5::Widgets
++ ${PYTHON_LIBRARIES}
+ PRIVATE
+- pybind11::embed
+ albert::lib
+ xdg
+ )