summaryrefslogtreecommitdiff
path: root/x11-misc/alacarte/alacarte-3.42.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
commit93a93e9a3b53c1a73142a305ea1f8136846942ee (patch)
treeb9791a06ab3284e27b568412c59316c66240c682 /x11-misc/alacarte/alacarte-3.42.0.ebuild
parent2771f79232c273bc2a57d23bf335dd81ccf6af28 (diff)
gentoo resync : 22.12.2021
Diffstat (limited to 'x11-misc/alacarte/alacarte-3.42.0.ebuild')
-rw-r--r--x11-misc/alacarte/alacarte-3.42.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/x11-misc/alacarte/alacarte-3.42.0.ebuild b/x11-misc/alacarte/alacarte-3.42.0.ebuild
new file mode 100644
index 000000000000..6ed197189c5b
--- /dev/null
+++ b/x11-misc/alacarte/alacarte-3.42.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_REQ_USE="xml"
+
+inherit gnome2 python-single-r1
+
+DESCRIPTION="Simple GNOME menu editor"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/alacarte"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+COMMON_DEPEND="
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep 'dev-python/pygobject:3[${PYTHON_USEDEP}]')
+ >=gnome-base/gnome-menus-3.5.3:3[introspection]
+"
+RDEPEND="${COMMON_DEPEND}
+ x11-libs/gdk-pixbuf:2[introspection]
+ x11-libs/gtk+:3[introspection]
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-util/intltool-0.40.0
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_install() {
+ gnome2_src_install
+ python_optimize
+}