summaryrefslogtreecommitdiff
path: root/x11-libs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-04 20:01:09 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-04 20:01:09 +0000
commit3daf38ec350b4e25244c69eea165b18afd090459 (patch)
tree5489bd5abdccd746fe68e98b9164e887bfbcfde4 /x11-libs
parent84bfe2244c544bae8dcaffbaf4cfb80f59f88f64 (diff)
gentoo auto-resync : 04:01:2024 - 20:01:09
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/Manifest.gzbin18361 -> 18361 bytes
-rw-r--r--x11-libs/pixman/Manifest4
-rw-r--r--x11-libs/pixman/pixman-0.43.0.ebuild68
-rw-r--r--x11-libs/pixman/pixman-9999.ebuild9
4 files changed, 75 insertions, 6 deletions
diff --git a/x11-libs/Manifest.gz b/x11-libs/Manifest.gz
index 0267b4f12b53..81ff2b704390 100644
--- a/x11-libs/Manifest.gz
+++ b/x11-libs/Manifest.gz
Binary files differ
diff --git a/x11-libs/pixman/Manifest b/x11-libs/pixman/Manifest
index 61e155176ec4..71b449cfa3c1 100644
--- a/x11-libs/pixman/Manifest
+++ b/x11-libs/pixman/Manifest
@@ -1,4 +1,6 @@
DIST pixman-0.42.2.tar.xz 652984 BLAKE2B 6286a9d064a5a24017fccbb0a6e9f6ef932077c2e33ec043826d4a7a6c707c9111d3de4b806cbcdb47fc2794f1f930d24d078de1ff2912061967db0890540957 SHA512 3476e2676e66756b1af61b1e532cd80c985c191fb7956eb01702b419726cce99e79163b7f287f74f66414680e7396d13c3fee525cd663f12b6ac4877070ff4e8
+DIST pixman-0.43.0.tar.xz 638236 BLAKE2B 1a807d4d5598a5fe6077d6bbc7786cba41a698a1f03801cc5367ade8707500ee215a0faf65afe85f9e040b0380f1074c2fdfd31c0805dc41a4e5e34e36416764 SHA512 a90399b8c6aec218abb2f419fb5d6894acf9f4c7acb4fd3893b0b7c805ba47c82ee7efb363be59bb1a15b6997b2dddb7dba062a165503b035e1124fff1b271c9
EBUILD pixman-0.42.2.ebuild 2154 BLAKE2B a70bb012160d42a2161407b435c0f079fc6dae548042f2e3c6fde16a37dfccf0cfd2712c2fbfd03e8bd1c8de662efc36021f6fdb0e0846312257ea35e0213b01 SHA512 121d4e66a5a43a3c126cf486c15191827429c2f861aa44ab851c50f2ca5faf466668af36ff7500d54ff4089e01acc21a16baa405512c5bfd19962f742b20e123
-EBUILD pixman-9999.ebuild 2149 BLAKE2B e60b7521d99f19ef7fd9956f7ccb43873805524857cb96a5efe28dbe55fd7c65962b6fcc94dd74421adf3fd8458c7266a7b6ea7e115863b07e6ac16e23eaf516 SHA512 ff5f34fc0cb59f9edf59f5a4be4d48bbe4bb54aff89709ce62b8262af229cbf0acd3847a40e89e78454e66578512854b3c20c96fac71450e04ba00c1c4900b44
+EBUILD pixman-0.43.0.ebuild 2165 BLAKE2B b4203fc7f0f7561d14f178809db7405c620d1582c8af2b2e0934a9de2a9e2bb0ff9c1261e1a27571e80d8fcf700634968b585c06732b466f60c7fa3cbab2b86b SHA512 f85c5ddd7a98c312c2045c77ebb0ed96b2915808a02faafe16313836da0e91acf2201a2c08dd66e96623c48ecd87a5f5c00856b8555d23510afd324aa45920cb
+EBUILD pixman-9999.ebuild 2165 BLAKE2B b4203fc7f0f7561d14f178809db7405c620d1582c8af2b2e0934a9de2a9e2bb0ff9c1261e1a27571e80d8fcf700634968b585c06732b466f60c7fa3cbab2b86b SHA512 f85c5ddd7a98c312c2045c77ebb0ed96b2915808a02faafe16313836da0e91acf2201a2c08dd66e96623c48ecd87a5f5c00856b8555d23510afd324aa45920cb
MISC metadata.xml 483 BLAKE2B 4302fc025e7ce3dfb1b2f099371f0b3263942203ffd50730c40afe491feb003d2ec17cbf8ddd4ad3c1c0d752c46b87dd944e907b6c31a6ffdcaab7b518c247fb SHA512 f4777b9c1ae7527be4f354836c51142b095ab27dd56b173a6e0b7146ad68257136f326ff7c0fa564706dcc53aebe9171d8f844bab026c139cab717c559bf2a5e
diff --git a/x11-libs/pixman/pixman-0.43.0.ebuild b/x11-libs/pixman/pixman-0.43.0.ebuild
new file mode 100644
index 000000000000..64f5bc702b84
--- /dev/null
+++ b/x11-libs/pixman/pixman-0.43.0.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+EGIT_REPO_URI="https://gitlab.freedesktop.org/pixman/pixman.git"
+
+if [[ ${PV} = 9999* ]]; then
+ GIT_ECLASS="git-r3"
+fi
+
+inherit ${GIT_ECLASS} flag-o-matic meson-multilib multiprocessing toolchain-funcs
+
+DESCRIPTION="Low-level pixel manipulation routines"
+HOMEPAGE="http://www.pixman.org/ https://gitlab.freedesktop.org/pixman/pixman/"
+if [[ ${PV} != 9999* ]]; then
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+ SRC_URI="https://www.x.org/releases/individual/lib/${P}.tar.xz"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="cpu_flags_ppc_altivec cpu_flags_arm_iwmmxt cpu_flags_arm_iwmmxt2 cpu_flags_arm_neon loongson2f cpu_flags_x86_mmxext cpu_flags_x86_sse2 cpu_flags_x86_ssse3 static-libs test"
+RESTRICT="!test? ( test )"
+
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use test && tc-check-openmp
+}
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use test && tc-check-openmp
+}
+
+multilib_src_configure() {
+ if ( use arm || use arm64 ) && tc-is-clang ; then
+ # See bug #768138 and https://gitlab.freedesktop.org/pixman/pixman/-/issues/46
+ append-cflags $(test-flags-CC -fno-integrated-as)
+ fi
+
+ local emesonargs=(
+ $(meson_feature cpu_flags_arm_iwmmxt iwmmxt)
+ $(meson_use cpu_flags_arm_iwmmxt2 iwmmxt2)
+ $(meson_feature cpu_flags_x86_mmxext mmx)
+ $(meson_feature cpu_flags_x86_sse2 sse2)
+ $(meson_feature cpu_flags_x86_ssse3 ssse3)
+ $(meson_feature cpu_flags_ppc_altivec vmx)
+ $(meson_feature loongson2f loongson-mmi)
+ $(meson_feature test openmp) # only used in unit tests
+ $(meson_feature test tests)
+ -Ddefault_library=$(usex static-libs both shared)
+ -Ddemos=disabled
+ -Dgtk=disabled
+ -Dlibpng=disabled
+ )
+
+ if [[ ${ABI} == arm64 ]]; then
+ emesonargs+=($(meson_feature cpu_flags_arm_neon a64-neon))
+ elif [[ ${ABI} == arm ]]; then
+ emesonargs+=($(meson_feature cpu_flags_arm_neon neon))
+ fi
+
+ meson_src_configure
+}
+
+multilib_src_test() {
+ export OMP_NUM_THREADS=$(makeopts_jobs)
+ meson_src_test -t 100
+}
diff --git a/x11-libs/pixman/pixman-9999.ebuild b/x11-libs/pixman/pixman-9999.ebuild
index fa237942c444..64f5bc702b84 100644
--- a/x11-libs/pixman/pixman-9999.ebuild
+++ b/x11-libs/pixman/pixman-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -13,10 +13,8 @@ inherit ${GIT_ECLASS} flag-o-matic meson-multilib multiprocessing toolchain-func
DESCRIPTION="Low-level pixel manipulation routines"
HOMEPAGE="http://www.pixman.org/ https://gitlab.freedesktop.org/pixman/pixman/"
-if [[ ${PV} = 9999* ]]; then
- SRC_URI=""
-else
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+if [[ ${PV} != 9999* ]]; then
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
SRC_URI="https://www.x.org/releases/individual/lib/${P}.tar.xz"
fi
@@ -50,6 +48,7 @@ multilib_src_configure() {
$(meson_feature test openmp) # only used in unit tests
$(meson_feature test tests)
-Ddefault_library=$(usex static-libs both shared)
+ -Ddemos=disabled
-Dgtk=disabled
-Dlibpng=disabled
)