summaryrefslogtreecommitdiff
path: root/x11-libs/xpa/xpa-2.1.18.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-20 14:27:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-20 14:27:17 +0000
commit5bb9ff1ee56d2b5e75e01a7f066d8b0cec84ec02 (patch)
tree66e860a5099bcad013f1cf667255dc372a7c11b3 /x11-libs/xpa/xpa-2.1.18.ebuild
parent7218e1b46bceac05841e90472501742d905fb3fc (diff)
gentoo resync : 20.03.2021
Diffstat (limited to 'x11-libs/xpa/xpa-2.1.18.ebuild')
-rw-r--r--x11-libs/xpa/xpa-2.1.18.ebuild22
1 files changed, 14 insertions, 8 deletions
diff --git a/x11-libs/xpa/xpa-2.1.18.ebuild b/x11-libs/xpa/xpa-2.1.18.ebuild
index 623d26c31983..984f56d2241d 100644
--- a/x11-libs/xpa/xpa-2.1.18.ebuild
+++ b/x11-libs/xpa/xpa-2.1.18.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit eutils autotools
+inherit autotools toolchain-funcs
DESCRIPTION="Messaging system providing communication between programs"
HOMEPAGE="https://github.com/ericmandel/xpa"
@@ -12,7 +12,7 @@ SRC_URI="https://github.com/ericmandel/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.g
LICENSE="LGPL-2.1"
SLOT="0/1"
KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc static-libs"
+IUSE="doc"
RDEPEND="
dev-lang/tcl:0=
@@ -26,12 +26,13 @@ PATCHES=(
src_prepare() {
default
- sed -e "s:\${LINK}:\${LINK} ${LDFLAGS}:" \
- -i mklib || die
+ sed -e "s:\${LINK}:\${LINK} ${LDFLAGS}:" -i mklib || die
eautoconf
}
src_configure() {
+ tc-export AR CC
+
econf \
--enable-shared \
--enable-threaded-xpans \
@@ -47,11 +48,16 @@ src_compile() {
src_install() {
dodir /usr/$(get_libdir)
emake INSTALL_ROOT="${D}" install
+
insinto /usr/$(get_libdir)/tclxpa
doins pkgIndex.tcl
- mv "${ED}"/usr/$(get_libdir)/libtclxpa* \
+
+ mv "${ED}"/usr/$(get_libdir)/libtclxpa* \
"${ED}"/usr/$(get_libdir)/tclxpa/ || die
+
dodoc README
use doc && dodoc doc/*.pdf && dodoc doc/*.html
- use static-libs || rm -f "${ED}"/usr/$(get_libdir)/*.a
+
+ # no static archives
+ rm "${ED}"/usr/$(get_libdir)/libxpa.a || die
}