summaryrefslogtreecommitdiff
path: root/x11-libs/xcb-util-cursor
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-19 01:57:29 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-19 01:57:29 +0100
commit84a400be40cf32d9e536ae34ebf14ad06ad6b8d6 (patch)
tree96ec24229ee5d9a7ed293011d39fa5a6438cab2d /x11-libs/xcb-util-cursor
parentd1262423b614597cd55d30370eb8de6bfa8f0899 (diff)
gentoo auto-resync : 19:10:2022 - 01:57:29
Diffstat (limited to 'x11-libs/xcb-util-cursor')
-rw-r--r--x11-libs/xcb-util-cursor/Manifest2
-rw-r--r--x11-libs/xcb-util-cursor/xcb-util-cursor-0.1.4.ebuild25
2 files changed, 27 insertions, 0 deletions
diff --git a/x11-libs/xcb-util-cursor/Manifest b/x11-libs/xcb-util-cursor/Manifest
index 678c61f91c16..26e76d8c4739 100644
--- a/x11-libs/xcb-util-cursor/Manifest
+++ b/x11-libs/xcb-util-cursor/Manifest
@@ -1,3 +1,5 @@
DIST xcb-util-cursor-0.1.3.tar.bz2 295224 BLAKE2B 7a1a89c0f326f4ac0768110c4aa5a7818ddace1f231f6a0dcfacaf8b157a2d6aae53f5278a02cb945822d83eccb8a01ebb14ab98e8828d8f1d506e42f51431ba SHA512 be5eee7b268b18f356d6aae04820a7e1c51397dac9020d876df379e833200255b5194269541c245a9b4ac286edad4cfe44dae8e4fcfd16a4726dd7553c104c21
+DIST xcb-util-cursor-0.1.4.tar.xz 265508 BLAKE2B 8d7eac0116652833e1835e9c7454bc859901e146b06985b3926fd5f7568d92f2249ef6ea17c2202fa247e36bb998ba5b76fa519e92ca5cd51eb778169c88218c SHA512 d27dd59a4d7ded9994dca77774421dd9533e3ee823b880af35d3219bd7340c89fbc61d1d0fa10e2991de2cac9e6395e09497769d7b8728eedc691e76649107b1
EBUILD xcb-util-cursor-0.1.3-r4.ebuild 1025 BLAKE2B e1cee4ee659ea5ecdf9c3d315e1c7fa0ee4c2593353524a7de929031fc629b3030a1ce2f9998e9d6dfcf1335e9adf9b7cb6db28aa8e01e20bf45263933237a3a SHA512 7c2ba922ab6841a56c63ae67003bc962cf0b3ccdb76896f76b269c7d2c89464da6d2a6c1c183bf0828a706c884eb46f99af6e8deb1080a775559d62580fe673b
+EBUILD xcb-util-cursor-0.1.4.ebuild 1057 BLAKE2B d6bc76f6ebcc9d67c4ef40a214b4d6ebdc3fe3cd9d9405ca93ddaf2551c442b84abeff4448d98c9b5c1e34228a85bd3fab914232175ce1e3fdec807a8e0b3018 SHA512 930f1494f8f5dc2530242e55951e92dc6c6b37563936acf3b24bd78777dc157d34891fb1d09b13680aedfc7b9b322522d9013e29ea07bd8724c76eb2e6cbebee
MISC metadata.xml 344 BLAKE2B 7350bdaa3994406d2c539c1e580759e17729eba1b935c15802e0fcdcb5194ffc2655148bc0a5b1c40329b887e9c41fb26964286e8fc5a29cfae2ce721cb00f01 SHA512 38736ab0f5b649781a67f911269e622c22b8ff75963818552aa772ef460691285260c057581226e00b2ebb9a7ff94c3bca863351ec1d916bd9e0a50537a8caa9
diff --git a/x11-libs/xcb-util-cursor/xcb-util-cursor-0.1.4.ebuild b/x11-libs/xcb-util-cursor/xcb-util-cursor-0.1.4.ebuild
new file mode 100644
index 000000000000..3f3659032f51
--- /dev/null
+++ b/x11-libs/xcb-util-cursor/xcb-util-cursor-0.1.4.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+XORG_MULTILIB=yes
+XORG_TARBALL_SUFFIX="xz"
+inherit xorg-3
+
+DESCRIPTION="X C-language Bindings sample implementations"
+HOMEPAGE="https://xcb.freedesktop.org/ https://gitlab.freedesktop.org/xorg/lib/libxcb-cursor"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x64-solaris"
+
+RDEPEND=">=x11-libs/libxcb-1.9.1:=[${MULTILIB_USEDEP}]
+ >=x11-libs/xcb-util-image-0.3.9-r1[${MULTILIB_USEDEP}]
+ >=x11-libs/xcb-util-renderutil-0.3.9[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}
+ >=x11-base/xcb-proto-1.8-r3:=
+ x11-base/xorg-proto"
+BDEPEND=">=dev-util/gperf-3.0.1"
+
+XORG_CONFIGURE_OPTIONS=(
+ --with-cursorpath='~/.cursors:~/.icons:/usr/local/share/cursors/xorg-x11:/usr/local/share/cursors:/usr/local/share/icons:/usr/local/share/pixmaps:/usr/share/cursors/xorg-x11:/usr/share/cursors:/usr/share/pixmaps/xorg-x11:/usr/share/icons:/usr/share/pixmaps'
+)