summaryrefslogtreecommitdiff
path: root/x11-libs/xbae/xbae-4.60.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /x11-libs/xbae/xbae-4.60.4.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'x11-libs/xbae/xbae-4.60.4.ebuild')
-rw-r--r--x11-libs/xbae/xbae-4.60.4.ebuild64
1 files changed, 64 insertions, 0 deletions
diff --git a/x11-libs/xbae/xbae-4.60.4.ebuild b/x11-libs/xbae/xbae-4.60.4.ebuild
new file mode 100644
index 000000000000..b4d5e7e4ae29
--- /dev/null
+++ b/x11-libs/xbae/xbae-4.60.4.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+
+inherit autotools-utils
+
+DESCRIPTION="Motif-based widget to display a grid of cells as a spreadsheet"
+HOMEPAGE="http://xbae.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux"
+SLOT="0"
+IUSE="doc examples static-libs"
+
+RDEPEND="
+ x11-libs/motif:0
+ x11-libs/libXau
+ x11-libs/libXdmcp
+ x11-libs/libXext
+ x11-libs/libXmu
+ x11-libs/libXpm
+ x11-libs/libXt"
+
+DEPEND="${RDEPEND}"
+
+# tests need X display
+# and are interactive so virtualx will not help
+RESTRICT=test
+
+PATCHES=(
+ "${FILESDIR}"/${P}-tmpl.patch
+ "${FILESDIR}"/${P}-lxmp.patch
+ "${FILESDIR}"/${P}-Makefile.in.patch
+ )
+
+src_configure() {
+ local myeconfargs=( --enable-production )
+ autotools-utils_src_configure
+}
+
+src_test() {
+ cd ${AUTOTOOLS_BUILD_DIR}/examples
+ emake
+ "${S}"/examples/testall
+ emake clean
+}
+
+src_install() {
+ autotools-utils_src_install
+
+ insinto /usr/share/aclocal
+ doins ac_find_xbae.m4
+
+ use doc && dohtml -r doc/*
+
+ if use examples; then
+ find examples -name '*akefile*' -delete || die
+ rm examples/{testall,extest} || die
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}