summaryrefslogtreecommitdiff
path: root/x11-libs/tslib/tslib-1.22.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
commitd99093fb4bb5652015c06274d64083daa2439e4f (patch)
treecf61513204d97974179580065e85df5c8009087c /x11-libs/tslib/tslib-1.22.ebuild
parent463397cf1e064185110fe57c568d73f99a06f5d1 (diff)
gentoo resync : 03.03.2021
Diffstat (limited to 'x11-libs/tslib/tslib-1.22.ebuild')
-rw-r--r--x11-libs/tslib/tslib-1.22.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/x11-libs/tslib/tslib-1.22.ebuild b/x11-libs/tslib/tslib-1.22.ebuild
new file mode 100644
index 000000000000..1fadd84c49a0
--- /dev/null
+++ b/x11-libs/tslib/tslib-1.22.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+CMAKE_ECLASS=cmake
+inherit cmake-multilib
+
+DESCRIPTION="Touchscreen Access Library"
+HOMEPAGE="https://github.com/kergoth/tslib"
+SRC_URI="https://github.com/libts/tslib/releases/download/${PV}/${P}.tar.xz"
+
+LICENSE="LGPL-2 uinput? ( GPL-2+ )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="evdev sdl uinput"
+
+BDEPEND="
+ evdev? ( virtual/pkgconfig )
+"
+DEPEND="
+ evdev? ( dev-libs/libevdev[${MULTILIB_USEDEP}] )
+ sdl? ( media-libs/libsdl2[${MULTILIB_USEDEP}] )
+"
+RDEPEND="${DEPEND}"
+
+DOCS=( AUTHORS NEWS README{,.md} )
+
+PATCHES=( "${FILESDIR}/${PN}-1.21-optional-utils.patch" )
+
+src_configure() {
+ my_configure() {
+ local mycmakeargs=(
+ -Denable-input-evdev=$(usex evdev)
+ -DENABLE_TOOLS=$(usex uinput $(multilib_is_native_abi && echo ON || echo OFF) OFF)
+ -DENABLE_UTILS=$(multilib_is_native_abi && echo ON || echo OFF)
+ -Denable-arctic2=ON
+ -Denable-collie=ON
+ -Denable-corgi=ON
+ -Denable-cy8mrln-palmpre=ON
+ -Denable-dejitter=ON
+ -Denable-dmc=ON
+ -Denable-dmc_dus3000=ON
+ -Denable-galax=ON
+ -Denable-h3600=ON
+ -Denable-input=ON
+ -Denable-linear-h2200=ON
+ -Denable-linear=ON
+ -Denable-mk712=ON
+ -Denable-one-wire-ts-input=ON
+ -Denable-pthres=ON
+ -Denable-tatung=ON
+ -Denable-ucb1x00=ON
+ -Denable-variance=ON
+ )
+ multilib_is_native_abi && mycmakeargs+=( -Dwith-sdl=$(usex sdl) )
+
+ cmake_src_configure
+ }
+ multilib_parallel_foreach_abi my_configure
+}