summaryrefslogtreecommitdiff
path: root/x11-libs/tslib/tslib-1.21.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /x11-libs/tslib/tslib-1.21.ebuild
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'x11-libs/tslib/tslib-1.21.ebuild')
-rw-r--r--x11-libs/tslib/tslib-1.21.ebuild60
1 files changed, 0 insertions, 60 deletions
diff --git a/x11-libs/tslib/tslib-1.21.ebuild b/x11-libs/tslib/tslib-1.21.ebuild
deleted file mode 100644
index 85369585a3b0..000000000000
--- a/x11-libs/tslib/tslib-1.21.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake-multilib
-
-DESCRIPTION="Touchscreen Access Library"
-HOMEPAGE="https://github.com/kergoth/tslib"
-SRC_URI="https://github.com/libts/tslib/releases/download/${PV}/${P}.tar.xz"
-
-LICENSE="LGPL-2 uinput? ( GPL-2+ )"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~m68k ~mips ppc ppc64 s390 sparc x86"
-IUSE="evdev sdl uinput"
-
-BDEPEND="
- evdev? ( virtual/pkgconfig )
-"
-DEPEND="
- evdev? ( dev-libs/libevdev[${MULTILIB_USEDEP}] )
- sdl? ( media-libs/libsdl2[${MULTILIB_USEDEP}] )
-"
-RDEPEND="${DEPEND}"
-
-DOCS=( AUTHORS NEWS README{,.md} )
-
-PATCHES=( "${FILESDIR}/${P}-optional-utils.patch" )
-
-src_configure() {
- my_configure() {
- local mycmakeargs=(
- -Denable-input-evdev=$(usex evdev)
- -DENABLE_TOOLS=$(usex uinput $(multilib_is_native_abi && echo ON || echo OFF) OFF)
- -DENABLE_UTILS=$(multilib_is_native_abi && echo ON || echo OFF)
- -Denable-arctic2=ON
- -Denable-collie=ON
- -Denable-corgi=ON
- -Denable-cy8mrln-palmpre=ON
- -Denable-dejitter=ON
- -Denable-dmc=ON
- -Denable-dmc_dus3000=ON
- -Denable-galax=ON
- -Denable-h3600=ON
- -Denable-input=ON
- -Denable-linear-h2200=ON
- -Denable-linear=ON
- -Denable-mk712=ON
- -Denable-one-wire-ts-input=ON
- -Denable-pthres=ON
- -Denable-tatung=ON
- -Denable-ucb1x00=ON
- -Denable-variance=ON
- )
- multilib_is_native_abi && mycmakeargs+=( -Dwith-sdl=$(usex sdl) )
-
- cmake-utils_src_configure
- }
- multilib_parallel_foreach_abi my_configure
-}