summaryrefslogtreecommitdiff
path: root/x11-libs/scw/scw-0.4.7-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
commit9ee6d97c2883d42f204a533a8bc1f4562df778fb (patch)
treeb690ddc0ca30f1472887edbb0b8313629bfcbbb2 /x11-libs/scw/scw-0.4.7-r2.ebuild
parentb17a3ef12038de50228bade1f05502c74e135321 (diff)
gentoo resync : 16.09.2020
Diffstat (limited to 'x11-libs/scw/scw-0.4.7-r2.ebuild')
-rw-r--r--x11-libs/scw/scw-0.4.7-r2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/x11-libs/scw/scw-0.4.7-r2.ebuild b/x11-libs/scw/scw-0.4.7-r2.ebuild
new file mode 100644
index 000000000000..a180f163479a
--- /dev/null
+++ b/x11-libs/scw/scw-0.4.7-r2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A GTK+ widget set specifically designed for chat programs"
+HOMEPAGE="http://scwwidgets.googlepages.com"
+SRC_URI="http://scwwidgets.googlepages.com/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 x86"
+IUSE="doc"
+
+RDEPEND="
+ dev-libs/glib:2
+ x11-libs/gtk+:2"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/glib-utils
+ virtual/pkgconfig
+ doc? ( dev-util/gtk-doc )"
+
+src_configure() {
+ econf \
+ --disable-static \
+ $(use_enable doc gtk-doc)
+}
+
+src_install() {
+ default
+
+ # no static archives
+ find "${ED}" -name '*.la' -delete || die
+}