summaryrefslogtreecommitdiff
path: root/x11-libs/pixman/pixman-0.42.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-02 21:10:25 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-02 21:10:25 +0000
commitd05150f06fa67b115a83f822b1e285dca011e1b7 (patch)
tree86d728b5108b361faf2f421e2d4f3b03a85b7837 /x11-libs/pixman/pixman-0.42.2.ebuild
parentbe524496e3171d5eab8c56570dd4342a880c3264 (diff)
gentoo auto-resync : 02:11:2022 - 21:10:25
Diffstat (limited to 'x11-libs/pixman/pixman-0.42.2.ebuild')
-rw-r--r--x11-libs/pixman/pixman-0.42.2.ebuild64
1 files changed, 64 insertions, 0 deletions
diff --git a/x11-libs/pixman/pixman-0.42.2.ebuild b/x11-libs/pixman/pixman-0.42.2.ebuild
new file mode 100644
index 000000000000..0fbef29030a3
--- /dev/null
+++ b/x11-libs/pixman/pixman-0.42.2.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+EGIT_REPO_URI="https://gitlab.freedesktop.org/pixman/pixman.git"
+
+if [[ ${PV} = 9999* ]]; then
+ GIT_ECLASS="git-r3"
+fi
+
+inherit ${GIT_ECLASS} flag-o-matic meson-multilib multiprocessing toolchain-funcs
+
+DESCRIPTION="Low-level pixel manipulation routines"
+HOMEPAGE="http://www.pixman.org/ https://gitlab.freedesktop.org/pixman/pixman/"
+if [[ ${PV} = 9999* ]]; then
+ SRC_URI=""
+else
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
+ SRC_URI="https://www.x.org/releases/individual/lib/${P}.tar.xz"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="cpu_flags_ppc_altivec cpu_flags_arm_iwmmxt cpu_flags_arm_iwmmxt2 cpu_flags_arm_neon loongson2f cpu_flags_x86_mmxext cpu_flags_x86_sse2 cpu_flags_x86_ssse3 static-libs test"
+RESTRICT="!test? ( test )"
+
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use test && tc-check-openmp
+}
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use test && tc-check-openmp
+}
+
+multilib_src_configure() {
+ if use arm && tc-is-clang ; then
+ # See bug #768138 and https://gitlab.freedesktop.org/pixman/pixman/-/issues/46
+ append-cflags $(test-flags-CC -fno-integrated-as)
+ fi
+
+ local emesonargs=(
+ $(meson_feature cpu_flags_arm_iwmmxt iwmmxt)
+ $(meson_use cpu_flags_arm_iwmmxt2 iwmmxt2)
+ $(meson_feature cpu_flags_x86_mmxext mmx)
+ $(meson_feature cpu_flags_x86_sse2 sse2)
+ $(meson_feature cpu_flags_x86_ssse3 ssse3)
+ $(meson_feature cpu_flags_ppc_altivec vmx)
+ $(meson_feature cpu_flags_arm_neon neon)
+ $(meson_feature cpu_flags_arm_neon a64-neon)
+ $(meson_feature loongson2f loongson-mmi)
+ $(meson_feature test openmp) # only used in unit tests
+ $(meson_feature test tests)
+ -Ddefault_library=$(usex static-libs both shared)
+ -Dgtk=disabled
+ -Dlibpng=disabled
+ )
+ meson_src_configure
+}
+
+multilib_src_test() {
+ export OMP_NUM_THREADS=$(makeopts_jobs)
+ meson_src_test -t 100
+}