summaryrefslogtreecommitdiff
path: root/x11-libs/pixman/pixman-0.38.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-29 11:38:31 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-29 11:38:31 +0100
commit90c88731bd036e5698b281fbc0a5f3aa4c9983ac (patch)
tree83fc5facb6b12be510a37bc3d241cc63e965b13a /x11-libs/pixman/pixman-0.38.4.ebuild
parentfeb0daf81d888e9160f9f94502de09b66f2a63fd (diff)
gentoo resync : 29.06.2020
Diffstat (limited to 'x11-libs/pixman/pixman-0.38.4.ebuild')
-rw-r--r--x11-libs/pixman/pixman-0.38.4.ebuild63
1 files changed, 0 insertions, 63 deletions
diff --git a/x11-libs/pixman/pixman-0.38.4.ebuild b/x11-libs/pixman/pixman-0.38.4.ebuild
deleted file mode 100644
index e327798978a0..000000000000
--- a/x11-libs/pixman/pixman-0.38.4.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-EGIT_REPO_URI="https://gitlab.freedesktop.org/pixman/pixman.git"
-
-if [[ ${PV} = 9999* ]]; then
- GIT_ECLASS="git-r3"
-fi
-
-inherit ${GIT_ECLASS} meson multilib-minimal multiprocessing toolchain-funcs
-
-DESCRIPTION="Low-level pixel manipulation routines"
-HOMEPAGE="http://www.pixman.org/ https://gitlab.freedesktop.org/pixman/pixman/"
-if [[ ${PV} = 9999* ]]; then
- SRC_URI=""
-else
- KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
- SRC_URI="https://www.x.org/releases/individual/lib/${P}.tar.gz"
-fi
-
-LICENSE="MIT"
-SLOT="0"
-IUSE="altivec cpu_flags_arm_iwmmxt cpu_flags_arm_iwmmxt2 loongson2f cpu_flags_x86_mmxext neon cpu_flags_x86_sse2 cpu_flags_x86_ssse3"
-
-src_unpack() {
- default
- [[ $PV = 9999* ]] && git-r3_src_unpack
-}
-
-multilib_src_configure() {
- local openmp=disabled
- tc-has-openmp && openmp=enabled
-
- local emesonargs=(
- $(meson_feature cpu_flags_arm_iwmmxt iwmmxt)
- $(meson_use cpu_flags_arm_iwmmxt2 iwmmxt2)
- $(meson_feature cpu_flags_x86_mmxext mmx)
- $(meson_feature cpu_flags_x86_sse2 sse2)
- $(meson_feature cpu_flags_x86_ssse3 ssse3)
- $(meson_feature altivec vmx)
- $(meson_feature neon neon)
- $(meson_feature loongson2f loongson-mmi)
- -Dgtk=disabled
- -Dlibpng=disabled
- -Dopenmp=$openmp # only used in unit tests
- )
- meson_src_configure
-}
-
-multilib_src_compile() {
- meson_src_compile
-}
-
-multilib_src_test() {
- export OMP_NUM_THREADS=$(makeopts_jobs)
- meson test -v -C "${BUILD_DIR}" -t 100
-}
-
-multilib_src_install() {
- meson_src_install
-}