summaryrefslogtreecommitdiff
path: root/x11-libs/libxkbcommon
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /x11-libs/libxkbcommon
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'x11-libs/libxkbcommon')
-rw-r--r--x11-libs/libxkbcommon/Manifest4
-rw-r--r--x11-libs/libxkbcommon/libxkbcommon-1.4.0.ebuild62
-rw-r--r--x11-libs/libxkbcommon/metadata.xml3
3 files changed, 68 insertions, 1 deletions
diff --git a/x11-libs/libxkbcommon/Manifest b/x11-libs/libxkbcommon/Manifest
index 556f9addcaef..e669c7246a05 100644
--- a/x11-libs/libxkbcommon/Manifest
+++ b/x11-libs/libxkbcommon/Manifest
@@ -1,3 +1,5 @@
DIST libxkbcommon-1.3.1.tar.xz 471036 BLAKE2B c46d39876bd4477fe838e17e744ed04388417cfae8bb77c7de48237d31f51fe230d2705733dc0873253b48c61530fbe932e4da7317217c31a7897702fa1d03b4 SHA512 3b2cf6ae9ba4dc8b6fe702ac1fa700034fbc9bd147c73bd2cd93546bcfb71865734b3e46bad35a8fd618ed97266a02dad1dc966c63e6b10404a64919459d933e
+DIST libxkbcommon-1.4.0.tar.xz 471948 BLAKE2B 5b0a155a3a47adb7302db01f3daa0ef81993a9754b032b01f1cdbd53af74d15df95dc6c9334860211a28272b246f66978ad6e409db74a242afb13c17dc25b76e SHA512 7dd86952c036a6a78455b1ba05b53fcff9d6f133bb01c83fa860b4eaec3fc26bb0b5535948bcc2dafbd27204c3c91d01404ca9fc52896cc36af509384797d4f1
EBUILD libxkbcommon-1.3.1.ebuild 1474 BLAKE2B 6fad57ab223145b1f966714970d6e21bc16841405a569e68a505587c7ac2fedaab111be7b58d0d99bc700c4dc8c6e3723e49b1594e2d6033519a640530908515 SHA512 1e78ed395916ed6e9c2691ae7113ba90cdb0123e9ca2d675ff3ea6d22da9dfbe91771131a6ef8a7a1ac6fcbee6238ff88761180ee3ea7e60da066d549b9aab21
-MISC metadata.xml 326 BLAKE2B d18efe3aa2e5fef21aac673bf0c7e951e4e998a9182f1372a343aea035be05252e195d62d991677c90d78dd8ffd89b77c45e4235c3c757e85399c064db7af9e0 SHA512 b6f5d79d6a1243c3bf0511d95748a943545e143242feae120c6932559f003caf3e15de1f56f12f177dba9c00ccbbfb3f8080c7ee95856e401561e67ad0a0a0ea
+EBUILD libxkbcommon-1.4.0.ebuild 1545 BLAKE2B d2a04e235709b1fc5c259ecf529eb87a5824bbdc3057741b4cd09b81ca2ec1e1a79b71185282a61ab08049ec4cd2e961827f8e85c2034fb1ac281ad86722c225 SHA512 88dbedf85c6bc890e3c345d5e2ec57245d4e164bc539a5658e449b6410d7c96f90cf19d0d0813c80e057a7f837e92aec7d493253acff758f9c453bb435411726
+MISC metadata.xml 392 BLAKE2B 387cc216299e7c312552b0fa7abdd744203daff7bc5a51ef5b7d2bcfd39b83904308c8bb2b66f2459f77f593e18fc8ade017491fa45e698e8e6bfce03a819df8 SHA512 0ab9850b467605c1050d70ca526d2a4c2957e3ec9f56113fcabeb9d4a79cb8636ab077f66e17c7e05b79aad6948a7e89a83e5d8c48197ab016a7f5b2f2886f42
diff --git a/x11-libs/libxkbcommon/libxkbcommon-1.4.0.ebuild b/x11-libs/libxkbcommon/libxkbcommon-1.4.0.ebuild
new file mode 100644
index 000000000000..91654e01156c
--- /dev/null
+++ b/x11-libs/libxkbcommon/libxkbcommon-1.4.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ ${PV} = *9999* ]]; then
+ GIT_ECLASS="git-r3"
+ EGIT_REPO_URI="https://github.com/xkbcommon/${PN}"
+else
+ SRC_URI="https://xkbcommon.org/download/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+fi
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit meson-multilib ${GIT_ECLASS} python-any-r1 virtualx
+
+DESCRIPTION="keymap handling library for toolkits and window systems"
+HOMEPAGE="https://xkbcommon.org/ https://github.com/xkbcommon/libxkbcommon/"
+LICENSE="MIT"
+IUSE="doc static-libs test tools wayland X"
+RESTRICT="!test? ( test )"
+SLOT="0"
+
+BDEPEND="
+ sys-devel/bison
+ doc? ( app-doc/doxygen )
+ test? ( ${PYTHON_DEPS} )
+ wayland? ( dev-util/wayland-scanner )
+"
+RDEPEND="
+ X? ( >=x11-libs/libxcb-1.10:=[${MULTILIB_USEDEP},xkb] )
+ wayland? ( >=dev-libs/wayland-1.2.0 )
+ dev-libs/libxml2[${MULTILIB_USEDEP}]
+ x11-misc/compose-tables
+"
+DEPEND="${RDEPEND}
+ X? ( x11-base/xorg-proto )
+ wayland? ( >=dev-libs/wayland-protocols-1.12 )
+"
+
+pkg_setup() {
+ if use test; then
+ python-any-r1_pkg_setup
+ fi
+}
+
+multilib_src_configure() {
+ local emesonargs=(
+ -Ddefault_library="$(usex static-libs both shared)"
+ -Dxkb-config-root="${EPREFIX}/usr/share/X11/xkb"
+ $(meson_native_use_bool tools enable-tools)
+ $(meson_use X enable-x11)
+ $(meson_native_use_bool doc enable-docs)
+ $(meson_use wayland enable-wayland)
+ )
+ meson_src_configure
+}
+
+multilib_src_test() {
+ virtx meson_src_test
+}
diff --git a/x11-libs/libxkbcommon/metadata.xml b/x11-libs/libxkbcommon/metadata.xml
index 9527efe6ae50..045195581cc6 100644
--- a/x11-libs/libxkbcommon/metadata.xml
+++ b/x11-libs/libxkbcommon/metadata.xml
@@ -5,6 +5,9 @@
<email>x11@gentoo.org</email>
<name>X11</name>
</maintainer>
+ <use>
+ <flag name="tools">Build the xkbcli tools</flag>
+ </use>
<upstream>
<remote-id type="cpe">cpe:/a:xkbcommon:libxkbcommon</remote-id>
</upstream>