summaryrefslogtreecommitdiff
path: root/x11-libs/libvdpau/libvdpau-1.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-09-06 10:28:05 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-09-06 10:28:05 +0100
commitf1af93971b7490792d8541bc790e0d8c6d787059 (patch)
treea38046712bbc3a3844d77452d16c84e716caa3d4 /x11-libs/libvdpau/libvdpau-1.3.ebuild
parentfc637fb28da700da71ec2064d65ca5a7a31b9c6c (diff)
gentoo resync : 06.08.2019
Diffstat (limited to 'x11-libs/libvdpau/libvdpau-1.3.ebuild')
-rw-r--r--x11-libs/libvdpau/libvdpau-1.3.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/x11-libs/libvdpau/libvdpau-1.3.ebuild b/x11-libs/libvdpau/libvdpau-1.3.ebuild
new file mode 100644
index 000000000000..2dc4d12a5faa
--- /dev/null
+++ b/x11-libs/libvdpau/libvdpau-1.3.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+VIRTUALX_REQUIRED="test"
+inherit flag-o-matic meson virtualx multilib-minimal
+
+DESCRIPTION="VDPAU wrapper and trace libraries"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/VDPAU"
+SRC_URI="https://gitlab.freedesktop.org/vdpau/${PN}/-/archive/${PV}/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm64 ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="doc dri"
+
+RDEPEND="
+ >=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]
+ dri? ( >=x11-libs/libXext-1.3.2[${MULTILIB_USEDEP}] )
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+ doc? (
+ app-doc/doxygen
+ media-gfx/graphviz
+ virtual/latex-base
+ )
+ dri? ( x11-base/xorg-proto )
+"
+
+src_prepare() {
+ sed -i -e "/^docdir/s|${PN}|${PF}|g" doc/meson.build || die
+ default
+}
+
+multilib_src_configure() {
+ append-cppflags -D_GNU_SOURCE
+ local emesonargs=(
+ -Ddri2=$(usex dri true false)
+ -Ddocumentation=$(usex doc true false)
+ )
+ meson_src_configure
+}
+
+multilib_src_compile() {
+ meson_src_compile
+}
+multilib_src_test() {
+ virtx meson_src_test
+}
+
+multilib_src_install() {
+ meson_src_install
+ find "${ED}" -name '*.la' -delete || die
+}