summaryrefslogtreecommitdiff
path: root/x11-libs/libtinynotify/libtinynotify-0.2.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /x11-libs/libtinynotify/libtinynotify-0.2.1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'x11-libs/libtinynotify/libtinynotify-0.2.1.ebuild')
-rw-r--r--x11-libs/libtinynotify/libtinynotify-0.2.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/x11-libs/libtinynotify/libtinynotify-0.2.1.ebuild b/x11-libs/libtinynotify/libtinynotify-0.2.1.ebuild
new file mode 100644
index 000000000000..b87cfbb96ab0
--- /dev/null
+++ b/x11-libs/libtinynotify/libtinynotify-0.2.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="A lightweight implementation of Desktop Notification Spec"
+HOMEPAGE="https://github.com/mgorny/libtinynotify/"
+SRC_URI="https://github.com/mgorny/libtinynotify/releases/download/${P}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug doc static-libs"
+
+RDEPEND="sys-apps/dbus:0="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( >=dev-util/gtk-doc-1.18 )"
+
+DOCS=( README )
+
+src_configure() {
+ local myconf=(
+ $(use_enable debug)
+ $(use_enable doc gtk-doc)
+ $(use_enable static-libs static)
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete
+}