summaryrefslogtreecommitdiff
path: root/x11-libs/librfm/librfm-5.3.16.3-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /x11-libs/librfm/librfm-5.3.16.3-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'x11-libs/librfm/librfm-5.3.16.3-r1.ebuild')
-rw-r--r--x11-libs/librfm/librfm-5.3.16.3-r1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/x11-libs/librfm/librfm-5.3.16.3-r1.ebuild b/x11-libs/librfm/librfm-5.3.16.3-r1.ebuild
new file mode 100644
index 000000000000..ee20c76b2fe4
--- /dev/null
+++ b/x11-libs/librfm/librfm-5.3.16.3-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools eutils
+
+MY_P="${PN}5-${PV}"
+
+DESCRIPTION="The basic library used by some rfm applications, such as Rodent filemanager"
+HOMEPAGE="http://xffm.org/libxffm.html"
+SRC_URI="mirror://sourceforge/xffm/${PN}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-libs/glib-2.22.5:2
+ >=dev-libs/libdbh-5.0.13
+ >=dev-libs/libtubo-5.0.13
+ >=dev-libs/libxml2-2.4.0:2
+ >=dev-libs/libzip-0.9:0=
+ >=gnome-base/librsvg-2.26:2
+ >=x11-libs/cairo-1.12.6[X]
+ >=x11-libs/gtk+-3.12:3[X]
+ >=x11-libs/pango-1.28.0[X]
+ !<x11-misc/rodent-5
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ default
+ sed -i -e "s:-O2:${CFLAGS}:" m4/rfm-conditionals.m4 || die
+ eautoreconf
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}