summaryrefslogtreecommitdiff
path: root/x11-libs/libpciaccess
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-09 17:41:38 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-09 17:41:38 +0100
commit7b7a5ff63901698b7b993201e07bcaf8d0e5db2f (patch)
tree2c27f993f9f52d5aa2f304b51ab34cc2a2f3cf1d /x11-libs/libpciaccess
parent7a58deff37cc7d12967dc30f49192d16cd110ee4 (diff)
gentoo auto-resync : 09:05:2023 - 17:41:38
Diffstat (limited to 'x11-libs/libpciaccess')
-rw-r--r--x11-libs/libpciaccess/Manifest2
-rw-r--r--x11-libs/libpciaccess/files/libpciaccess-0.17-musl-lfs.patch40
-rw-r--r--x11-libs/libpciaccess/libpciaccess-0.17-r1.ebuild33
3 files changed, 75 insertions, 0 deletions
diff --git a/x11-libs/libpciaccess/Manifest b/x11-libs/libpciaccess/Manifest
index f44af12ec5f1..69a87e82bf5e 100644
--- a/x11-libs/libpciaccess/Manifest
+++ b/x11-libs/libpciaccess/Manifest
@@ -1,3 +1,5 @@
+AUX libpciaccess-0.17-musl-lfs.patch 1579 BLAKE2B b7753c4e180287eb5c21d044c49557df6cb7c11e39470f234451f7681b774bf83a484ed3ed220d0ca019d2e9414116df9b7164514fe8302576b2612f35b9f171 SHA512 8f8085331dddd4b57e35b993f9c4f80f2c9623b31d9a74c7c44210866cca43f57ee747a0c8b6cb0dcd87f6fdb0e0dbb7c731ce519276f6864dce8065b2787023
DIST libpciaccess-0.17.tar.xz 331768 BLAKE2B 41539b3d6385fe7c42b562c7602f87b07730bbbeea7d65d3cc8e5af974ed5f9985b0779d51891493dd241a36bb171a3744e3b1f3fd30bee8a19bb5bd785f4c5f SHA512 8484605c66ef18c8d8a3e029a6d33e26fcaa450c1263790d89ac8b0a160ffb2dfceaa6140ac9ad7d8087283ecbec8ac801f757e44890d547c3cbecd2c922ca47
+EBUILD libpciaccess-0.17-r1.ebuild 765 BLAKE2B 56d88832ecda1c35ade77ad70064fc8543ccce48f232ef988d4ed933e89ca55360fd7c5ebee724fc0183509ceabbb5b91ec41e4d5e8deaf164badc74d98a7596 SHA512 91aa4f6c94ea28c98f12c3344205a4e82686f05fe8fb55790245322b9c8361f2289bc70e63e28d2f514cebca647f8193f69ba21b77555b81bef1a42ce826ccb7
EBUILD libpciaccess-0.17.ebuild 709 BLAKE2B 779c55305a8a2bb73899291d8299df720751ebcaad90cc90ea8c50c52a10e57bb7d05bc540131dd31c1a49143797b931c57566a78393af0f77c620371350662f SHA512 98448d8ffd67aead1d2a1edb84922ed98d9ebc8c77c448273ce4d315a834d2a44aaf3ad346770699db85e44fbe572118e8779eeb4f32c1b3e85504dd72d2af57
MISC metadata.xml 343 BLAKE2B 841587af1693a1a28bc87d7785e79805abf10ea86b5b2bc117b786f005eb18c2d4369a6b7668c7ae6d41de19f2820d2957007b3c5417706713b26ffb5e67ece5 SHA512 89fe0feea88e2fca82867d6ef538a88576626681d6cc1e14c96784d0f0ff7ac9f09434440e8aec295a4fc5e4b07a3b681592129c26777e6182d3369e0720b035
diff --git a/x11-libs/libpciaccess/files/libpciaccess-0.17-musl-lfs.patch b/x11-libs/libpciaccess/files/libpciaccess-0.17-musl-lfs.patch
new file mode 100644
index 000000000000..cfd7a1469b25
--- /dev/null
+++ b/x11-libs/libpciaccess/files/libpciaccess-0.17-musl-lfs.patch
@@ -0,0 +1,40 @@
+https://bugs.gentoo.org/905913
+https://gitlab.freedesktop.org/xorg/lib/libpciaccess/-/commit/833c86ce15cee2a84a37ae71015f236fd32615d9
+
+From 833c86ce15cee2a84a37ae71015f236fd32615d9 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Fri, 11 Nov 2022 11:15:58 -0800
+Subject: [PATCH] linux_sysfs: Use pwrite/pread instead of 64bit versions
+
+pread64/pwrite64 are aliased to pread/pwrite when largefile support is
+enabled e.g. using _FILE_OFFSET_BITS=64 macro
+
+This helps it compile on latest musl C library based systems where these
+functions are put under _LARGEFILE64_SOURCE which is to be removed once
+all packages start using 64bit off_t, it works with glibc becuase
+_GNU_SOURCE feature macro also defines _LARGEFILE64_SOURCE, thats not
+the case with musl
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+--- a/src/linux_sysfs.c
++++ b/src/linux_sysfs.c
+@@ -462,7 +462,7 @@ pci_device_linux_sysfs_read( struct pci_device * dev, void * data,
+
+
+ while ( temp_size > 0 ) {
+- const ssize_t bytes = pread64( fd, data_bytes, temp_size, offset );
++ const ssize_t bytes = pread( fd, data_bytes, temp_size, offset );
+
+ /* If zero bytes were read, then we assume it's the end of the
+ * config file.
+@@ -522,7 +522,7 @@ pci_device_linux_sysfs_write( struct pci_device * dev, const void * data,
+
+
+ while ( temp_size > 0 ) {
+- const ssize_t bytes = pwrite64( fd, data_bytes, temp_size, offset );
++ const ssize_t bytes = pwrite( fd, data_bytes, temp_size, offset );
+
+ /* If zero bytes were written, then we assume it's the end of the
+ * config file.
+--
+GitLab
diff --git a/x11-libs/libpciaccess/libpciaccess-0.17-r1.ebuild b/x11-libs/libpciaccess/libpciaccess-0.17-r1.ebuild
new file mode 100644
index 000000000000..7191e10bbbb0
--- /dev/null
+++ b/x11-libs/libpciaccess/libpciaccess-0.17-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+XORG_MULTILIB=yes
+XORG_TARBALL_SUFFIX="xz"
+inherit xorg-3 meson-multilib
+
+DESCRIPTION="Library providing generic access to the PCI bus and devices"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="zlib"
+
+DEPEND="
+ zlib? ( >=sys-libs/zlib-1.2.8-r1:=[${MULTILIB_USEDEP}] )"
+RDEPEND="${DEPEND}
+ sys-apps/hwdata"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-musl-lfs.patch
+)
+
+src_prepare() {
+ default
+}
+
+multilib_src_configure() {
+ local emesonargs=(
+ -Dpci-ids="${EPREFIX}"/usr/share/hwdata
+ $(meson_feature zlib)
+ )
+ meson_src_configure
+}