summaryrefslogtreecommitdiff
path: root/x11-libs/liboglappth/liboglappth-1.0.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
commit9ee6d97c2883d42f204a533a8bc1f4562df778fb (patch)
treeb690ddc0ca30f1472887edbb0b8313629bfcbbb2 /x11-libs/liboglappth/liboglappth-1.0.0-r1.ebuild
parentb17a3ef12038de50228bade1f05502c74e135321 (diff)
gentoo resync : 16.09.2020
Diffstat (limited to 'x11-libs/liboglappth/liboglappth-1.0.0-r1.ebuild')
-rw-r--r--x11-libs/liboglappth/liboglappth-1.0.0-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/x11-libs/liboglappth/liboglappth-1.0.0-r1.ebuild b/x11-libs/liboglappth/liboglappth-1.0.0-r1.ebuild
new file mode 100644
index 000000000000..eb68dba4208b
--- /dev/null
+++ b/x11-libs/liboglappth/liboglappth-1.0.0-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Libary for OpenGL applications with easy-to-code scene setup and selection"
+HOMEPAGE="http://www.bioinformatics.org/ghemical/"
+SRC_URI="http://www.bioinformatics.org/ghemical/download/current/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+
+RDEPEND="
+ virtual/opengl
+ media-libs/freeglut"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}"/gcc-4.3.patch )
+
+src_configure() {
+ econf --disable-static
+}
+
+src_install() {
+ default
+
+ # no static archives
+ find "${ED}" -name '*.la' -delete || die
+}