summaryrefslogtreecommitdiff
path: root/x11-libs/libnotify
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /x11-libs/libnotify
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'x11-libs/libnotify')
-rw-r--r--x11-libs/libnotify/Manifest2
-rw-r--r--x11-libs/libnotify/libnotify-0.7.9.ebuild63
2 files changed, 65 insertions, 0 deletions
diff --git a/x11-libs/libnotify/Manifest b/x11-libs/libnotify/Manifest
index c02564ed257c..887382007d40 100644
--- a/x11-libs/libnotify/Manifest
+++ b/x11-libs/libnotify/Manifest
@@ -1,3 +1,5 @@
DIST libnotify-0.7.8.tar.xz 108436 BLAKE2B 0a73eabe58faca55e16774cda6f649ab3187bd73a1f87b538d5098f390571a6a34078883dbd2447731d6e4cae315d8286e9e8acc06e85590c8b05a693a83e7f7 SHA512 9973d7a1af5dd7cfbaa0d0d2c9e72a40df9d814967fde47e95763a69690cc4ed32ecf713d75f91f3dff99a693eff9dab963be124e0530ebf231d517a44e75e94
+DIST libnotify-0.7.9.tar.xz 98148 BLAKE2B 4728d00a204cd1003e8171a54c23bb975c0477c245c1175558f27555763113ec8bd7abd7ef81f6bad2b98604efe436d843958e77473436e68560775804473383 SHA512 8a842b50777279efdb7d96a836a546c47decad158a4f03f7ffc818860d1f6276a657619e4f4a19a4e2f5ad55e0371c793420d50d802983700e8c342273b73874
EBUILD libnotify-0.7.8.ebuild 1487 BLAKE2B 8a9775a033e8ec479ade134d3c92323d5bd4c19844355a8bddac9802fa124bdafbc2662d0bc0d938d03d79b6e363a9fe6a16008ee21baf308c9af04ec5aea3c8 SHA512 f9bac7d8cd49a15213e9b16abdeb0ed69cde22a59bac91f4a7bd2bca5189db275efb48bc5ce147246ca44468d801c95135f70b504c2ad74fec92e4fb8ea8c345
+EBUILD libnotify-0.7.9.ebuild 1549 BLAKE2B 31fe70608662e8abc4cddce42580e46511b51dc01e0e4e388798482e74f0115be36c68809bb3c340b532cdcf57784d608e35b01c17672a6d9031ce434e055a5e SHA512 283fd36e4a8fa41298b91e5c478950ae93f4d8f18c1520cf96bf324dd5f257462246307a917c775dc83573704429503cd614d27ac83acdffec0f7ae7e72ffe35
MISC metadata.xml 276 BLAKE2B 889856a4e8b234e03eb27d32a4bce748a561f98ca0faa36de124e58e3832d804d1492f59db1154c4ec0e2e0e46c7d9cf38d9911ee83dd0863699581000610f31 SHA512 673180ba375ea401c0a8f197d516417b3f9361b11943c71bac88b0d0b1407b0bc657f5763c6fb6e429cc6ee112869a2247083fe56743e9ce918855c0ea929e59
diff --git a/x11-libs/libnotify/libnotify-0.7.9.ebuild b/x11-libs/libnotify/libnotify-0.7.9.ebuild
new file mode 100644
index 000000000000..9783bf0f9890
--- /dev/null
+++ b/x11-libs/libnotify/libnotify-0.7.9.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit gnome.org meson multilib-minimal xdg-utils
+
+DESCRIPTION="A library for sending desktop notifications"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/libnotify"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE="gtk-doc +introspection test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ app-eselect/eselect-notify-send
+ >=dev-libs/glib-2.26:2[${MULTILIB_USEDEP}]
+ x11-libs/gdk-pixbuf:2[${MULTILIB_USEDEP}]
+ introspection? ( >=dev-libs/gobject-introspection-1.54:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ >=dev-libs/gobject-introspection-common-1.32
+ dev-util/glib-utils
+ virtual/pkgconfig
+ app-text/docbook-xsl-ns-stylesheets
+ dev-libs/libxslt
+ gtk-doc? ( dev-util/gtk-doc
+ app-text/docbook-xml-dtd:4.1.2 )
+ test? ( x11-libs/gtk+:3[${MULTILIB_USEDEP}] )
+"
+PDEPEND="virtual/notification-daemon"
+
+src_prepare() {
+ default
+ xdg_environment_reset
+}
+
+multilib_src_configure() {
+ local emesonargs=(
+ -Dtests="$(usex test true false)"
+ -Dintrospection="$(multilib_native_usex introspection enabled disabled)"
+ -Dgtk_doc=$(multilib_native_usex gtk-doc true false)
+ -Ddocbook_docs=disabled
+ )
+ meson_src_configure
+}
+
+multilib_src_install() {
+ meson_src_install
+
+ mv "${ED}"/usr/bin/{,libnotify-}notify-send || die #379941
+}
+
+pkg_postinst() {
+ eselect notify-send update ifunset
+}
+
+pkg_postrm() {
+ eselect notify-send update ifunset
+}