summaryrefslogtreecommitdiff
path: root/x11-libs/libfakeXinerama
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-09-03 20:56:28 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-09-03 20:56:28 +0100
commitfbda87924e6faa7a1919f1a2b4182490bde5ec5c (patch)
treef3114a4ed212a754756adce027aeef3a4a1a2e2a /x11-libs/libfakeXinerama
parent3b08f674e3f771b49370edb144dab0958c8cf721 (diff)
gentoo resync : 03.09.2021
Diffstat (limited to 'x11-libs/libfakeXinerama')
-rw-r--r--x11-libs/libfakeXinerama/Manifest3
-rw-r--r--x11-libs/libfakeXinerama/libfakeXinerama-0.1.0.ebuild30
-rw-r--r--x11-libs/libfakeXinerama/metadata.xml11
3 files changed, 44 insertions, 0 deletions
diff --git a/x11-libs/libfakeXinerama/Manifest b/x11-libs/libfakeXinerama/Manifest
new file mode 100644
index 000000000000..8f16b07dc156
--- /dev/null
+++ b/x11-libs/libfakeXinerama/Manifest
@@ -0,0 +1,3 @@
+DIST libfakeXinerama-0.1.0.tar.bz2 3191 BLAKE2B 3f3572a64c6aafc71df9db7dc0c88125f4eb53dc7ae5dd22a704964664f3e21423241892b92be3591dffeca264660b1dd0880989e8088091d0731105ffec224b SHA512 6b2cd7a3ebd751d869b8afd1c129412f7bc8e8098d7f27a1781078c33f5fa644374524d3e7f5a7b9cf0297edb848d6ff7ec8f29d312e2af0c88d248c751ef907
+EBUILD libfakeXinerama-0.1.0.ebuild 787 BLAKE2B 774ae49392a9fbfa69f2bf31a83d16aad2f43acc10593dd7fb0b069a7c6fad902de7b7880e400be811abc7fd00e3c3af99dfd491a7e92edfec1baf5f4254b229 SHA512 9747726361f8267732f197f68dcbbfe6cb6d9a6d0e3faeafb1e17d04bc09df35028c15bce3c5c2f7767519b30ac642a5570ccb10be3d77e59329c5c57be0c600
+MISC metadata.xml 336 BLAKE2B dd7b7eb65ba05e490666bf6d6e90205d8eb7d8e1d6de8dc8f30b8c7fe9f0d7cbf99825d32e63bdc15cbf35b335a11158912814e19afa8cf4fb7bad46c865d8a5 SHA512 9ce65bf7db78d04c22583c0337bc02443577964ccce2257c531ea4c5bdf7746995aa85c05034a7bf7ce217c41a405a50b2a5414023ad22e33a15682aa70fc6b7
diff --git a/x11-libs/libfakeXinerama/libfakeXinerama-0.1.0.ebuild b/x11-libs/libfakeXinerama/libfakeXinerama-0.1.0.ebuild
new file mode 100644
index 000000000000..d1a8f77f32ee
--- /dev/null
+++ b/x11-libs/libfakeXinerama/libfakeXinerama-0.1.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multilib toolchain-funcs
+
+DESCRIPTION="Fake library to override default libXinerama and expose custom screen dimensions"
+HOMEPAGE="https://github.com/Xpra-org/libfakeXinerama"
+SRC_URI="https://xpra.org/src/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ x11-libs/libX11
+ x11-libs/libXinerama
+"
+
+src_compile() {
+ libtool --tag=CC --mode=compile $(tc-getCC) -shared ${CFLAGS} -c ${PN#lib}.c || die
+ libtool --tag=CC --mode=link $(tc-getCC) -shared ${LDFLAGS} -Wl,-z,defs ${PN#lib}.lo \
+ -o ${PN}.la -rpath "${EPREFIX}/usr/$(get_libdir)" -version-number 1:0:0 || die
+}
+
+src_install() {
+ dolib.so .libs/${PN}$(get_libname)*
+ dodoc README.TXT
+}
diff --git a/x11-libs/libfakeXinerama/metadata.xml b/x11-libs/libfakeXinerama/metadata.xml
new file mode 100644
index 000000000000..d1e8c601f846
--- /dev/null
+++ b/x11-libs/libfakeXinerama/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>chewi@gentoo.org</email>
+ <name>James Le Cuirot</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">Xpra-org/libfakeXinerama</remote-id>
+ </upstream>
+</pkgmetadata>